Kicad automatic connect joint not connected

How to have Kicad automatically connect joints not perfectly connected just by 1-2 px, clearly told by 2 hollow/empty circles instead of smooth nothing there or a solid dot

It seems as though you have some elements “off grid” on your Schematic.

To fix the problem select the whole schematic then Right click anywhere on the schematic and then select: “align elements to grid”.

1 Like

But, be careful when you do this!
Even though this will fix connection problems in the future, moving components to the correct grid may unintentionally connect wires - look over your schematic carefully when you issue this command.

And don’t use a grid of anything other than 50 (units) when laying out your schematic. KiCad relies on default connection points being on this base grid. Only ever use a smaller grid to move elements like text or graphical features when you need to polish and adjust the final design.

1 Like

If the align elements/grid size advice does not work on the misaligned
symbols/elements open same in symbol editor and realign the pin(s)
to the 50 units grid.

You may have to realign the pins using a smaller ‘units’ setting first
in symbol editor because the ‘snap to grid’ is autoset to 50 units
and moving misaligned pins will realign them 50 units + pixel offset.
Zoom in to magnify and ensure a pin location is correct, then reset
the symbol editor to the 50 units default and use "Save As’ to finish.

What is actually grid of 50 (units) ?
Please help where to find it in setting i.e. preference and other recommended its related values

View / Grid properties
Right click “Background Grid” Icon on top Left Hand side then Grid Properties.

The 50(units) is shown as 50 mils. This grid is used to place all pins of all symbols on Kicad.

Edit: as a further comment, this 50mil grid is a meaningless “actual size” because when the page size or printing is changed the distance changes.
Realistically, this 50mil grid should be called the “symbol placement & symbol movement grid”. If any other grid is used with symbols, wires will no longer attach to pins.

1 Like

To work with individual schematic components
‘Right Button Click’ on the component and select
Edit with Symbol Editor
In Symbol Editor ‘Click On’ View Tab —> Grid Properties …
Then follow instructions as above.

When I started to use KiCad I changed grid to position values and references. And of course it happened that I forgot to set it back to 50.
But someone told me to just switch grid off while moving texts.
In V5 I was doing it by using CTRL+SHIFT while moving text, but now (V7) CTRL alone is enough.

1 Like

This, I try to never switch grids as its just too easy to forget to switch back

1 Like

no such 50 mils, or 50 mm if it’s meant so

only there Current grid has dropdown values list of fraction of inch

User defined grid
ready to be set in pair of values

Fast switching grid

Should set 50 mm, if 50 mils it’s meant so, in ‘User defined grid’
then use it as current grid ?

This is the 50mils grid setting.
This setting should always be used when placing symbols on a Schematic so wires will conveniently attach.
This setting should also always be used when placing pins whilst creating symbols in the Symbol Editor

All other grid settings should be reserved for Graphics and Text.

no such 50 mils, on here

Immediately below the grid background button on the right hand side of your screen are the three “use dimension buttons” (See my screen grab just above).

They are “in” , “mil” & “mm”.

If you have “in” (inch) selected, the correct grid will show: Grid:0.0500 in (1.2700mm)
If you have “mil” (thousandths of inch) selected, the correct grid will show: Grid:50.00mils (1.2700mm)
If you have “mm” (millimetres) selected, the correct grid will show: Grid: 1.2700mm (50.00mil)

These are all the same distance.

no such mils unit on v. 6.0.11

PLAN B

I suggest you make a separate schematic containing only the
unconnectable component(s) and add one known connectable component
such as a resistor or capacitor and then zip the schematic
and upload it to this post.
You could simply delete all other components in the project schematic
then add a good resistor or capacitor then ‘save as’

EXAMPLE
Filename: noconnect.kicad_sch
Zip Filename: noconnect.zip

Also zoom in to fit to objects and take a snapshot and post that too.

Then you won’t have to reveal your project design if it is confidential.
Someone may be able to help or even realign the parts in question
and re-upload to you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.