KiCad and JLCPCB: .pos file working for one project, not the other

I have two projects under KiCad that I am trying to get working with the JLCPCB surface mount assembly.

One project I started from scratch and I have no difficulties at all. The JLCPCB surface mount preview worked fine and the boards came in as ordered. Any problems on the boards were – well, my fault.

For the second project, I am borrowing someone’s design and just tweaked a few things here and there to try to use the SMD assembly service, and it looks like there is some kind of a difference in the configuration of the files. No matter what I do, I cannot get the parts to preview under the JLCPCB screens.

My uninformed assumption is that the origin is calculated differently… and as such I’ve tried to set the grid origin to different places around the board. (I am assuming the red cross hair is origin marker). I’ve also tried setting the auxiliary axis origin to no effect.

I have no idea where to even look at this point, so I’m open to ady help or advice.

Particulars:

  • KiCad version 5.1.5(stuff)
  • OS: Linux Mint
  • Using jlc-kicad-tools to do the convert, but the position x, y is the same as the KiCad generated files.

If seeing the repo is easier, I’ve included it below.