KiCad 8 on Windows 7 (How To)

I know KiCad is not supported on Windows 7. Nevertheless there can be reasons one uses Windows 7 (that’s my case).
Here are the steps to make KiCad 8 run on Windows 7.
Someone might need this. I hope KiCad team won’t remove this possibility :slight_smile:
Be aware that KiCad 8 is not supported on Windows 7, so please don’t complain if something does not work.

  1. You need Windows 10 machine to compile KiCad 8 from source code using MSYS2.
    Windows (MSYS2) | Developer Documentation | KiCad

  2. Download installer of KiCad 8, and manually unpack contents on Windows 7 machine (for instance to C:\Program Files\KiCad\8.0).

  3. Delete contents of C:\Program Files\KiCad\8.0\bin

  4. Copy contents of “C:\msys64\mingw64\bin” to “C:\Program Files\KiCad\8.0\bin”

  5. Copy folder “C:\msys64\mingw64\lib\python3.11” to “C:\Program Files\KiCad\8.0\lib\python3.11”

  6. Download and place “api-ms-win-core-path-l1-1-0.dll” to “C:\Program Files\KiCad\8.0\bin”
    Releases · nalexandru/api-ms-win-core-path-HACK · GitHub

It works for me. So I hope this helps someone else as well.


I have kicad8 installed on Virtual machine W10.
I installed MYSYS2 on virtual machine W10.

Q1-MYSYS2 don’t seem tu update. is it necessary?

Q2-What should I do to execute step 2 properly?

Tnks for your help :slight_smile:

It looks like you have some network problem. Maybe something wrong configured with you virtualization.

1 Like

Ok, I solve the restriction with network, school network have a lot of protection. this one solved.

It is difficult to me understand what I should to do until the step where on W7 I got a folder with all stuff inside.
My situation on W10

I reach this point.

Can you help me?

Best Regards, Luis Vasco

All I did, Unzip the official installer with 7Zip, and run Kicad. No compiling or anything. Run it says unsupported OS and continues.

Unzipping official installer worked in Kicad 7 for me. But Kicad 8 doesn’t work, because when I launch Schematic Editor it crashes. PCB Editor runs.