Kicad 8 issues

I have several Kicad 8 issues after I’ve upgraded the project from v7, I’m putting them all in one place:

  1. I cannot wire two components in my schematics. Seems the grid size issue. The wire goes either up or down another wire I want to connect to. Changing the grid size seems to have no effect at all. I remember I reduced the default grid size for this project by half in v7. So frustrating now.
  2. Legacy BOM scripts do not work. I tried to generate JLCPCB BOM using the same method I did in the past:
xsltproc -o "/home/dizcza/Projects/SRS/sdpsensor_kicad/sdpsensor_kicad.csv" "/home/dizcza/.local/share/kicad/8.0/plugins/bom2grouped_csv_jlcpcb.xsl" "/home/dizcza/Projects/SRS/sdpsensor_kicad/sdpsensor_kicad.xml"
Command error. Return code -1.
execvp(xsltproc, -o, /home/dizcza/Projects/SRS/sdpsensor_kicad/sdpsensor_kicad.csv, /home/dizcza/.local/share/kicad/8.0/plugins/bom2grouped_csv_jlcpcb.xsl, /home/dizcza/Projects/SRS/sdpsensor_kicad/sdpsensor_kicad.xml) failed with error 2!

I managed to do this with a new BOM-generating tool though. And I could not get rid of excluded from BOM components in my preview until I hit the Export button. It’s unintuitive. Please do something with excluded from BOM components in the preview: hide or at least gray them out.

  1. PCB JLC fabrication plugin does not work. It does not even appear in the upper top panel after I installed it. I understand that this might be an issue to the author but come on, do you really force plugin devs to quickly update to the recent major version or do you try supporting plugins that are written for an older version?

  2. I cannot create custom pads with custom rings/polygons. The menu in the choice list is present but the settings dialog (for defining custom polygons, top panel) is missing.

I’m switching back to v7 at the moment. I tried my best. The final choice came from being unable to run the fabrication plugin.

1 Like

Ah, I cannot open in v7 a project saved in v8.


Ok I’ve learned how to manually generate gerbers and drills acceptable in JLCPCB. Not a big deal.

To change the grid for your symbols, go to Preferences > Grids > Connected items
General rule is to avoid using symbol grid diffrent from default one.
Kicad8 offers different grids for different items, which allows to use coarse grid for Symbols and fine grid for Texts.

It’s not a big deal. However if you do it a lot (especially with JLC PCB assembly) it’s easier with the plugin. This one works best for me: “kicad-jlcpcb-tools”, however I don’t think it works flawlessly on KiCAD v8. The developer is very responsive, so feel free in v8 and report bugs on his GitHub:

1 Like

In addition to the grid override settings (new introduced by v8, see @fred4u ) you can enable/disable this 1) override mode on the left toolbar.
Look into the documentation Schematic Editor | 8.0 | English | Documentation | KiCad and search for “override”. This topic is already covered in the updated documentation - nice work from the writers.

4)custom pads: this was already changed in v7. your used “custom polygons, top panel” was already declared as legacy and with v8 this is completely removed.
The new way to define custom pads is to use the “Edit pad as graphic shape” mode:

  • select a pad (in FP-editor)
  • RMB-click → context menu → edit pad as graphic shape
  • note top yellow info bar noticing you: working in pad edit mode
  • draw any polygon/shape/… on the layer. These must overlap the original pad and form a closed, connected copper area.
  • RMB-click → context menu → end pad edit mode

All right, thanks for replies.

True. I overlooked it yesterday when I read the blog about the v8 release. I cannot believe though that you made the override true by default, breaking the behavior it was in v7. When you select a grid size from a drop-down menu (after a right click), you suspect to have a change but no change is made. Have you thought of adding a message to the user that they have forgotten to turn off the override button when they change any settings that override affects?

This seems to work, however, I cannot create a pad as a ring with a hole inside - the same behavior was in v7 and I thought maybe it has been fixed in v8, I’ll open a separate thread describing the issue.

So the only issue left is unintuitive BOM displaying items that should be excluded (though I really liked the new look of it, great job) and some old scripts do not work in the legacy BOM menu (well, it’s legacy anyway and with the new look of BOM menu it does not matter much).

Another issue I forgot to mention:

  1. I often show the footprint value instead of its designator in the PCB and previously I was able to select the layer on which the information should be displayed as text. Now there is only the show button in the footprint properties and it has no effect (the text does not appear at all). I read the v8 PCB reference manual and found no info w.r.t. this.

UPD 6. This is because I turned off F.Fab and B.Fab in the board setup… silly. But hey, another unintuitive behavior (can be ignored, most people I suspect have their Fab layers enabled so they would see something appear when they enable the footprint show property).

One issue I noticed is Fab layer text is shown regardless of if it is checked as visible or not I’ve only opened one design so far but this was a pretty glaring issue.

Try to uncheck Hidden text from “Objects” tab of Appearance panel.

Yes that was it, not sure why it defaulted to on though.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.