KiCad 7 upgrade on Ubuntu

When I do “sudo apt upgrade” on Ubuntu. I get a message that kicad is held back. It seems to be confused by several upgrade possibilities. What should do to always upgrade to the latest KiCad 7 release?

The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

$ apt list --upgradable -a
Listing… Done
kicad/focal 7.0.11~ubuntu20.04.1 amd64 [upgradable from: 7.0.10~ubuntu20.04.1]
kicad/now 7.0.10~ubuntu20.04.1 amd64 [installed,upgradable to: 7.0.11~ubuntu20.04.1]
kicad/focal 6.0.11-0-202302012048+2627ca5db0~126~ubuntu20.04.1 amd64
kicad/focal 5.1.5+dfsg1-2build2 amd64

This came up on a server forum a while back. It seems Ubuntu has a ‘staged’ introduction. You have to opt in to an early adopters setting somewhere to get ‘the latest’. Otherwise it is held back for a couple days to see if there is any problem. This really sux on a server where the user interface kinda by passes that setting and you get the update right away. Dangerous on a server.

Do you have 5 and 6 also installed?

The held back problem is sometimes also due to dependency issues.
Have you tried

sudo apt-get update
sudo apt-get dist-upgrade

This will make sure all your packages on the OS are up to date.
What version of Ubuntu are you running?

Otherwise leave it a few days and sometimes the problem just fixes itself due to Ubuntu phased updates

Thank for the comments,

I ran “sudo apt dist-upgrade” and that seems to have fixed the problem. I have kicad 1.0.11 now.

The Ubuntu hold back bothered me at first but now I am ok with it. They claim to be doing a staged rollout so that a few users do more testing before everybody gets it. On a server, I can see how that might get complicated.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.