KiCad 7 netlist doesn't work as supposed to

I am trying to learn Kicad with some projects. There is an issue I encountered.There is working connection in Schematic Editor but when I try to import netlist in PCB Editor some of the components like Led and Resistor there is no netlist connection.

You know that for several versions now using an intermediate netlist file is not the way to go from schematic to board?

1 Like

Can you give more detailed example or youtube link.

Videos are horrible because often it’s not obvious that they are out of date. Anything about v5 or deity forbid, v4, should be trashed.

Use the Getting Started document. But here’s a hint: you should be using the Update PCB from Schematic action under Tools I think (not at computer at the moment).


Using the Netlist export for KiCad has been deprecated for 5 years or more. It is only intended for unusual work flows and interfacing with external tools. As retiredfeline wrote, the recommended and normal way is to use Schematic Editor / Tools / Update PCB from Schematic [F8].


That said, exporting a netlist from the schematic editor and importing it to the PCB editor should still work flawlessly, so there may be a bug. If you share your zipped project someone may take a look at it.


One of the reason can be no compatibility between symbol and footprint (like symbol has pins A and K and footprint 1 and 2).


if I press (F8) there is an error

Error: D1 pad 2 not found in LED:LED_5MM-KIT.
Error: D1 pad 1 not found in LED:LED_5MM-KIT.
Error: D2 pad 2 not found in LED:LED_5MM-KIT.
Error: D2 pad 1 not found in LED:LED_5MM-KIT.

There is a difference between footprint assigned at schematic side and footprint present in board:

  • footprint assigned to D1/D2 (in schematic): LED:LED_5MM-KIT
  • footprint present in board: LED:LED_3MM

So on the next F8==update pcb from schematic the footprint on the board should change (if LED:LED_5MM-KIT is available - not on my installation).

The error-message “Error: D2 pad 1 not found in LED:LED_5MM-KIT.” points in the direction of @Piotr 's answer: the symbol and the choosen footprint are incompatible regarding pin-numbering (symbol) and pad-numbering (footprint).

For every pinnumber (in the symbol) there must exist a correseponding pad-number (in the footprint).

The currently used symbol shows pin-numbers 1+2 , so you need a footprint which contains two pads numbered 1+2. Not a footprint with pads numbered A+K.


Yes I did that different footprints I tried that also but It didn’t change either.
Ok now I got it.It works now.I should use with pin numbers.

I would like to add Volt-Ampermeter.Unfortunately I couldn’t find any symbol or footprint of it so I did my self a new one.But some of the pinouts didn’t show up as I expected.

But some of the pinouts didn’t show up as I expected.

And where is your problem exactly?

(If it’s that Pad 1+5 are displayed as “GND” in the board-picture:
that is a result from the schematic.
You have connected a label “5V_volt” and “Load_black” to pin 1+5 of the symbol, and these labels are also connected to the gnd-net. So all these nets are shorted together, getting the resulting netname gnd")

Btw.: it’s easier for the readers if you attach the archived project directly in your reply-answers, so I don’t need to download the project from git.

1 Like

Gnd_volt is not connected anywhere.
You also have 5V_Volt connected to GND

1 Like

Sorry that was my mistake

The pads in your footprint are numbered wrong(no number 1 or number 2 pads). Edit the footprint.

1 Like

Pin numbers are correct.Am I wrong?

It all looks ok now.

One thing I would change is the spacing between tracks - it’s a personal peference as should not make any difference but since you have lots of space on the board why route the tracks so close together all over the PCB:

Screenshot from 2023-03-24 07-20-18

By moving tracks/via slighlty you will also avoid this:

Screenshot from 2023-03-24 07-16-05

1 Like

Thank you all I’m very appreciated for your explanatory answers. My last issue how do you handle some times research projects under Kicad 6.0. I need to look through my project in kicad 6.0 computer but with new 7.0 we are not able to do that?

my recommendation:
Work with same version on all computers (choose the least common denominator), so in this case: v6.

But v6+v7 can be (at least on Win10/11) installed in parallel, so the better way: install v7 on all computers.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.