Kicad-7 footprints

hi everyone… i have a question on Kicad-7 in that i was using ver-6 and when i went to footprint association all most all were added automatically but in Kicad -7 it seems i have to add them all 1 x 1… is there a fix for this… it even happens with an 74LS ic or a Z80 dip … and in Version 6 i didn’t need to do it…thanks for any help…

How often do you use KiCad?

Reason I ask is that I am not aware of changes for this functionality, but there are a lot of different ways to assign footprints to schematic symbols. You can do it one at a time, but also in bulk, both in V6 and V7. Maybe you forgot the “bulk” options?

You can use Copy & Paste in Schematic Editor / Tools / Edit symbol Fields.
Another option is Schematic Editor / Tools / Assign Footprints. In that dialog you can select multiple fields by holding shift, and then a double click of one of the footprints in the **Filtered Footprints Results from the right side column.

I don’t remember automatic assignment.
I run the footprint assignment tool. It is very quick method for assigning and also highlights, with a quick scroll, which symbols still need footprints.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.