Kicad 7 does not recognize anymore libraries?

I found on the web similar issues, but I am not understanding what to do to fix it

I have some kicad_mod files, in a folder, which when trying to add them into the footprint libraries, they aren’t recognized, they aren’t shown

also old saved footprints, do seem to give the same issue, although before they were rightly installed

Sorry, have to ask these questions:
OS and kicad version. You’ll find them in Kicad / Help / About Kicad / Top RH corner, copy that and paste into this forum.

What footprint libraries, personal or Kicad?

I wonder what you are doing when:

In KiCad, footprint libraries are quite simple. Each file is a footprint, and a “Library” is just a folder.
So first get those footprints out of your “Downloads” folder, and put them in some directory of their own. After that go to KiCad / Preferences / Manage Footprint Libraries and then add the folder to the table by clicking on the little plus button in the lower left corner.

Also attach the relevant footprint-files in your reply. So we can see if it’s file-dependant or if it depends on your installation.

Application: KiCad x64 on x64

Version: (7.0.0), release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 12 2023 01:35:19
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

personal footprints
here’s an example of the libs that I am having issues (and all the others that I had)

yes but stuff it’s not shown either in the lib management, and in the window where you can copy and paste the footprint models like:

here is the example lib
and from the example screenshot you can see that when opening the folder via the footprint manager I can see nothing, although files are there because when copy and pasting, I have an error about renaming files or something (idr right now), also when I use the file explorer I can see them

then I go to the after mentioned window
and there is nothing

  • I tried the 4 footprints and all works as expected. So no problem with the Fp-files itself.
  • regarding your last screenshot “Choose footprint”-window: you have scrolled to far - the “M.2-Templates” library is alphabetically before the “Package_xxx”-libraries
  • Are you 110% sure the complete directory-path in the “Manage footprint libraries” window is correct? Have you tried to delete that entry, add a new entry and than freshly select the directory?
  • Have you tried to copy the 4 *.kicad_mod files into a existing footprint-library-directory, just to be sure “it works” in principle?

this is embarassing, it was all upp

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.