KiCAD 7 and 8 (windows 10) freezing and window becomes un-selectable

This problem happens with both kicad 7 and 8 on windows 10.

Description of the problem:

  1. Open PCB editor and open a property window for a footprint, etc. The window freezes and becomes un-selectable. I cannot move or close any open windows in KiCAD anymore. This also happens when opening the 3D pcb viewer. The program does not freeze (does not become unresponsive), but impossible to make changes in any open KiCAD windows.
  2. in the taskbar, right click kicad and “close all windows”. The “save changes?” dialog pops up, but is also un-selectable. The only way to close KiCAD is to end the process in task manager.
  3. Re-start windows. Then the problem goes away for some time, but it returns after kicad has been running for a while, or if it has been opened and closed several times.

What I tried:

  • Restarting windows helps the problem, but its not a permanent solution (the problem comes back after using it for a while)
  • Reinstalling kicad 7 and 8 does not solve the problem. (Do I need to clear some additional files after uninstalling it? )

Sounds bizarre, could you give the exact version of Kicad you have tried and in the meantime try 8.0.1v and see what happens please? and no should you not have to delete any files after an uninstall :grinning:

Are you running a multi-monitor setup? Seems to me like some modal window is displayed but not visible.

1 Like

Now I am using 8.0.1, and previously had the same problem with v7 (but not sure what version exactly, as I already uninstalled it)

I tried it with a single monitor and I still have this problem. I tried to press Alt-F4 to close any hidden windows, but nothing happens. Is there some way to detect if there is a modal window in the foreground ?

I’d try Win+Tab to present all open windows at once, then go back to KiCad. This may cause to rearrange the visible windows so the modal one locking your UI will show on top. Few times had similar issue, but always worked it out in some intuitive (i.e. more or less random) way.

Thank you for the suggestion, I tried it but it does not work either…

Does it mean it happens frequentyly to you and so it’s relatively easy to reproduce?
Can you try the following:
then Arrow up (one time)
then Enter?

(this should display modal window’s context menu, arrow up should go to close and Enter should commit close).

This problem happens every time I use KiCAD. I’m not exactly how long it takes to appear, but it only appears after my computer has been running for some time (maybe a few hours?) After restarting, it disappears. Could it be that there is some process running in the background after KiCAD is closed, but causes problems when it is opened subsequently?

I also tried pressing Alt+Space , Arrow up, Enter, as you suggested, but nothing changes.

Here is some more information that might be useful…

Occasionally, upon opening PCB Editor, I get an error message which says that the file is open elsewhere. Then another error message popped up that says:

“Got an error trying to lock C:\ … \filename.kicad_pcb: [json.exception.parse_error.101] parse error at line 1, column 1: attempting to parse an empty input; check that your input string or stream contains the expected JSON”

I still think there’s one more “OK” window displayed in a modal way (effectively locking everything elese) but for some reason it’s buried under other UI elements. The question remains, how to reach it…