KiCad 7.0.1 cannot find 3D models

Hi all
This is probably a beginner’s question, but I couldn’t find an answer by searching the forum.

I’m using Kicad 7.0.1, after upgrading from 6.x
When I try to display the 3D viewer, no 3D shapes appear, except for the components configured “by hand” and located in KIPRJMOD
By default, when I edit the properties of a “standard” component (in other words a default footprint library located in the default footprint path configured by the « Preference/configure path/ item),

  • The 3D model pointed in the 3D tab of the « footprint properties » window is always a wrl file
  • the equivalent STEP file is never found unless it is specified ‘by hand’ from the footprint properties
  • the path indicated by default is systematically ${KICAD6_3DMODEL_DIR}/path/footprint_name.wrl" (yes, KICAD6, even if the configured path indicates the kicad 7 3Dshape directory)

When a project has more than 150 decoupling caps and you have to configure the path to the footprint 150 times, it’s a little bit boring.

So my question is very simple:

  • how do I configure Kicad to indicate the path of the 3D shapes “by default”?
  • How to make sure that only 3D shapes in STEP format are taken into account ?
  • How to make sure that once a 3D shape is assigned to a footprint, all identical footprint are configured with the path of this very same 3D shape ?

A warm « thank you » to whom could find why my KiCad version is doomed

KiCad 7 will automatically interpret the KiCad 6 3D model variable appropriately, unless you also have ${KICAD6_3D_MODEL_DIR} defined in your path variables

I can’t see from your screenshot if you have a ${KICAD6_3D_MODEL_DIR} variable defined, but if you do you can delete the KICAD6 variable or set it to the same thing as the KICAD7 variable.

oh, Thanks gkeeth !
But alas, I don’t have any trace of a kicad6 variable in my defined path. Everything has been cleaned before installing V7.x, precisely to avoid this kind of persistance

The truth is beyond :- / and I have no idea in wich direction “beyond” is

I’m afraid this bug is related with a “hard coded” path somewhere.

… and I’m still unable to know how to define STP extension as default 3D type of file

still searching


why do you want to specify a STP? The default footprints are set up the way that they are for a reason: the 3D viewer will display the specified WRL file, which generally has nicer-looking materials, and the STEP exporter will automatically replace it with the corresponding STEP model so you get a mechanically-accurate STEP export for MCAD applications (you have to check the “subsitute similarly named models” option in the exporter).

As for the models not showing up, all I can suggest is that you double check you don’t have a ${KICAD6_3DMODEL_DIR} defined in Preferences → Configure Paths. The 3D models have worked for me in v7 on every platform I’ve tried:

I do notice that the second model path in your screenshot (the one you added) is not in the right format, so I wouldn’t expect it to work.

Hi Gkeeth

I really don’t care for an nice looking form, but for a mechanically accurate stp file format that Freecad plugin will easily use (the native step export capabilities in Kicad are more limited)
… and defining a wrl form to translate it later in a stp format don’t seems very efficient to me (why this 2 step operation ?).I’d better use the only format that can really be used in CAD, and the format generally available by default when creating a new 3D object with a parametric CAD software.

I’ve checked again and again my path config menu, and absolutely nothing is pointing or mentionning a kicad6 ressource. Kicad 7 has been installed from scratch, after a full kicad 6 uninstall.

> I do notice that the second model path in your screenshot (the one you added) is not in the right format, so I wouldn’t expect it to work


You’ve probably found the problem. Which model path are you talking about please? The one pointing on the IDC Step file ? (the only one that seems to work for me as it is the only one displaying the device)


Many people do care :slight_smile: This way works for both parties - you get the WRLs in the viewer, and STEPs in the MCAD export. If it were built from scratch today, it would probably be done the other way around. But changing that now creates its own issues.

I believe you that there’s nothing for v6 there, but I don’t know what else to suggest. (as a point of interest, a full uninstall and reinstall does not necessarily wipe your paths – uninstalling v6 won’t delete your preferences, which are stored separately, and on first launch of v7 you probably had the opportunity to import your v6 preferences). But if there’s no v6 path there then there’s no v6 path there.

I was pointing out the line:

which generally should be:


Note the ${} around the variable, and the / rather than : after the variable.

But testing it myself, that syntax seems to work for me, too, though I don’t know why.

Yep. I’ve notice the absence of brackets on each side of the variable, but this line has been created by Kicad itself, using the “folder” icon and pointing to the 3D form. I though that internal path naming conventions created by kicad were “canonical” enough to work :smiley:

Anyhow, I have enough abused of your patience and kindness, and really thank you for your help

I think the next option will be a complete chamanic re-install of Kicad… most of the time, it works (well… I hope so).

I though the stp file format has been a “future default standard” officially announced with the 5.0 edition, to comply with FreeCAD graphical formats. Wrl is a heavy legacy…

Thank you again gkeeth


this has been discussed here:

and at gitlab:

1 Like

Thanks for this “historical” precision
I thought I read something similar some years ago… and it sounds logical.
But I also understand that software evolution is not always a yellow brick road

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.