Kicad 6, no 3d components on 3dviewer

Hi. Fresh install, kicad 6.0.1, path to 3d models: KICAD6_3DMODEL_DIR C:\Program Files\KiCad\6.0\share\kicad\3dmodels\ but no component is showing in 3d viewer.
Is there a way I can make it work?


I couldn’t fix my problem. I know this issue is very common and I’m surprised it doesn’t have a solution.

You don’t provide very much information, including what you’ve tried, but I’m going to go ahead and assume that your problem is the same that many other people have run into and respond accordingly.

It is not true that it doesn’t have a solution. There are at least two solutions, although there is much discussion that confuses the issue and makes it hard to parse the solutions :slight_smile:

The issue is that your existing boards (created in v5) have v5 footprints embedded in them. The v5 footprints, in turn, have v5 model paths embedded in them that use a $KISYS3DMOD variable.

That variable is not defined in KiCad 6, so KiCad can’t find the models.

You have at least two options:

  1. Update the footprints in your board to match the updated footprints in the library, which have the v6 paths in them that tell KiCad where to find the models. You can update all of your models in a board at once with the menu item Tools → Update Footprints from Library…, although this will overwrite any footprint customizations you’ve made in the board. You can also go into the properties of each footprint one-by-one and click “Update Footprint from Library”. You’ll have to do this with each board you have.
  2. You can go into Preferences → Configure Paths… and define the “missing” variable and point it somewhere where the models will be found. You can either define $KISYS3DMOD and point it to the same place as $KICAD6_3DMODEL_DIR, or if you want to maintain separate libraries for v5 and v6 you can point your $KISYS3DMOD variable to your v5 library location. [this is the reason that new, v6-specific variables were introduced: so you can maintain two separate libraries, if you want]

Hope that helps; if not I’ll need some more info.


Thank you so much for your patience and your help. Indeed I had a kicad5 project and your option 1 worked for me. Maybe this solution seems so obvious for some experienced users but I just didn’t see it.
So when opening any kicad 5 proiject, first thing to do is Tools → Update Footprints from Library
However, may I suggest for future versions PCBNEW should ask if it can auto-update footprints for older projects?

Glad that worked. It’s not obvious – we should probably make an FAQ for it.

Edit: done, 3D models are missing in 3D viewer after updating to V6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.