Kicad 6: it crashes almost every time I load a project

With Kicad 6.0.1 (info below) almost every time I try to open a project it crashes.
Actually, I can often open the schematic without problems, but when I switch to the layout it crashes. Furthermore, if I open the layout without open the schematic the crash is almost there.

After 4-5 trials usually it works. Other times, I need to restart the PC and try again.

I did a search to understand if Kicad has a log file but I didn’t find anything.
Launching the executable from command line, I hoped it printed something useful. Instead nothing is shown.

But when the crash happens I read: Segmentation fault.

Application: KiCad

Version: 6.0.1-79c1e3a40b~116~ubuntu20.04.1, release build

wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-97-generic x86_64, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
Date: Jan 15 2022 20:26:22
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

What is your Linux distribution

It’s written above: Ubuntu 20.04

Crash is always a critical bug and should be fixed. Can you upload the zipped project here?

It’s possible to try to get some information using gdb (you can install it with apt). It would look like this:

You type “run” and kicad runs. When you get it to crash, gdb stops and you can type “backtrace” and it gives some information. Probably you should install kicad-dbg package first, it has debugging information which gives more useful information for backtrace, but it’s a large package.

1 Like

Is this related to a specific project?
Or with all your projects?

I’m trying to understand that. It seems it’s related to all my projects, but the behavior is quite strange. On some projects it happens more frequently on day, but on another those projects opens correctly and other show the issue - even without any edit made.

Until now, every time I run Kicad with gdb it worked fine…

It’s not unheard of that debugging makes it behave correctly and a crash appears only with a normal execution. Sadly, it’s impossible to fix it can’t be debugged.

It’s also possible to create a core dump automatically after a segfault which can be loaded to gdb and examined, but it’s unnecessarily difficult on Ubuntu. You can try and read for example 16.04 - Where do I find the core dump in ubuntu 16.04LTS? - Ask Ubuntu. If running through gdb doesn’t reproduce the problem, this may be the only chance.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.