Kicad 6 Arranging components within PCB

Greetings all

I’ve only just discovered KIcad and am getting to grips with the program. Forgive me if I don’t describe myself as a Noob as (in the UK) the word has a very derogatory meaning.

Anyway, I’ve gone through the schematic design process and am now (within the PCB editor), trying to arrange the components on the PCB and am struggling to place said components, as every time I try to accurately place a component it jumps all over the place, I.e. it won’t stay where I put it.

Is there a way of smoothly dragging a component to where “I” want to put in and not where the display “thinks” it should go - very frustrating.

Looking forward to any/all constructive responses.


Chris D

Are you stating that once you place a component, after some period of time, it moves itself? I’ve not encountered that issue with KiCad.

If you’re having difficulty with part placement it could be your grid setting. Components normally snap to the grid as you move them with the mouse. I use a .25mm grid (mostly) when placing components.

Also, stating which version of KiCad you’re using can help pinpoint issues.
Help->About KiCad, click the button “Copy Version Info” in the upper right corner and paste into your post.

Hi @bw41101 and welcome to the kicad forum.

The kicad grid is both handy and frustrating for me, and I have done quite a few boards with kicad.

I usually use a crude 1mm grid for board edge cuts and placement of connector-centers on the perimeter (when I have freedom to choose board size and connector positions) as I like nice neat numbers for the mechanical enclosure integration.

For routing I like a 0.1mm grid. When you go to move a component you can grab the center and it will drag onto the grid if it is off-grid. If you move a group of components you can also be careful to grab the center of one of the parts to keep the group on-grid. Even though I try to be careful, I often get to the final stages of a project only to find a bunch of parts with pick-n-place locations that are something like 12.836428, 27.746346, which really drives me crazy, but now I am getting to the point where I don’t care. The point is, kicad does not enforce parts staying on grid, so you need to be aware of that.

However, A really useful feature is locking (right-click on a part to find it). I lock the edge cuts, all of the mounting holes, perimeter connectors/switches… and any other important parts I don’t want to inadvertently nudge out of position. You can lock other parts as well if you want,

As others have mentioned, your problem is probably caused by using a Grid that is too coarse while you have the “Snap to Grid” function activated…

There are several remedies:

  • Change the grid to something finer as shown by @marekr . Footprints will still jump, just not as much.

  • Disable the “Snap to Grid” function (until you choose otherwise) in Preferences > PCB Editor > Display Options > Snap to Grid, then choose from the selection box. (Bottom function in Grid options group)

  • Disable the “Snap to Grid” function temporarily, by holding the CTRL key down while moving the footprint.

Yes, same here in Australia…means utterly stupid fool, sub-cretinous moron, total waste of space, Richard Cranium, etc.

The used term here for someone just starting is Newbee… sounds similar, entirely different meaning. :slightly_smiling_face:

Greetings all;

Many thanks for your responses - all of which have been very informative and have provided a solution to the issue that I was experiencing.

I was looking on line for a suitable PCB CAD program that could run on a 32bit system and Kicad was the only one that seemed to be available. Being a Linux user with a 32bit system, it was great that I was able to download and install this to my system.

I’ve still got a lot to learn of course, but that’s half the fun and (as a bonus) I’ve found using Kicad rather therapeutic as well.

Thanks again for all of your help - appreciated.


Chris - bw41101


It would be great if you supplied the solution to your problem.

Sometime in the future another troubled soul will be searching through this forum looking for a solution to “jumping” components/footprints, but will be dismayed to find no answer. :cry:

1 Like

A fair point indeed; basically (in this instance), the solutions turned out to be one or all of the following:

  • Selection of 0.0100 in (0.2540 mm) grid within the PCB editor
  • Disabling of the “Snap to Grid” function temporarily, by holding the
    CTRL key down while moving the footprint.
    Thanks again for all the help.


Chris (bw41101)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.