Kicad 6.99 Debian SID crashes with new/opening projects

Heya,
first time forum user here, medium term Kicad user though, been designing a few PCB with it and loving everything about this software…
… but the latest available APT isntallable build, which just seems to be pretty useless for me to do anything else than opening the very last project, but otherwise creating new ones, or opening other old ones, simply crashes Kicad.
I tried installing the latest stable kicad (5.xx) but that won’t open any of my projects, which have been done with 6.99 (5.99 before that, I’m a sucker for dev/nightly releases) because it says they’ve been made with a more recent version.

It seems this issue has been going on for a while (eg: Kicad 6 crash when opening pretty much anything) … and I wonder whether anyone had a solution.

I’m running Debian 11 sid, and haven’t tried compiling it myself (I’d rather avoid, but I could give it a try) …

Installing a version from the repositories was the result of realising that debian nightly releases stopped coming out since many months back and I also wonder why’s that?

Anyway, thanks for any insight!

Cheers,

JC

https://forum.kicad.info/t/can-a-project-edited-with-newer-version-of-kicad-be-opened-with-older-version/25302/2

Thanks @retiredfeline , I’ll have a look a that.

I still wonder whether the latest Knightly build, which afaik hasn’t been updated for Debian since “Date: Aug 18 2022 21:18:28” (from the build I have here), is broken for anyone else.
I don’t get any error if I launch kicad-nightly from the terminal, but I’m keen on giving as much information as possible.

I just ran it through ‘gdb’ and the bottom of the log is:

[New Thread 0x7ffff1e1f6c0 (LWP 45482)]
terminate called without an active exception
[Thread 0x7ffff1e1f6c0 (LWP 45482) exited]

Thread 1 "kicad" received signal SIGABRT, Aborted.
__pthread_kill_implementation (threadid=<optimized out>, signo=signo@entry=6, no_tid=no_tid@entry=0) at ./nptl/pthread_kill.c:44
44	./nptl/pthread_kill.c: No such file or directory.

anything useful?

Unfortunately not. You can try moving ~/.config/kicad to a different location and starting KiCad again.

If that works, please archive a copy of your settings and send it to me

That’s the first thing I tried. Hasn’t helped, unfortunately. Same crash with that folder deleted and started with fresh new configuration.

Next best guess is going to be video driver. But with a build from back in August it really could be anything. And it almost certainly is fixed already if it is a bug in the code that we know about

Well, I’ve just gone through the process and managed to successfully compile it… seems all working so far! :slight_smile:

Will keep this updated.
Cheers!