KiCAD 6.01 no symbols/footprints in Ubuntu 20.04

Hi, on my Ubuntu 20.04 I cloned repos from git: symbols, footprints and 3dmodels to the correct /usr/share/kicad folder. I’m able to see the symbol names, but when I click on them in the dialog, it doesn’t show preview of the symbol or it is not possible to add symbol by clicking OK.

I previously had kicad-nightly but I removed it from my system and deleted all the environment variables like KICAD6_SYMBOL_DIR so the Configure paths point to the correct directory.

Thanks for any tips.


I might have installed KiCAD 5 before, but I’m testing this on the new project.

I tried to follow [SOLVED] I can not get symbols out of library to put on my Schematic but with no luck.

Deleted ~/.config/kicad, restarted Kicad 6.01 and this dialog appears, but I cannot choose the first option which is suggested in the thread above.


Seems like I got it working. After I selected “Create an empty global symbol libary table” I wen’t to Symbol libraries, footprint libraries and clicked on the folder icon and added all of them. Then it started to work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.