KiCad 6.0 OpenGL problem

This is triggered by wxWidgets 3.1 having a manifest that includes the Win10 ID.
It is considered by multiple people on the internet to be an Intel GPU drive issue; but, I have no idea myself.

If you set the kicad.exe to work in Windows 8 compatible mode the problem goes away except for the 3d viewer that still fails to work.

Tim S.

Actually it’s our own manifest, we don’t use the wx one because it lacks things~~

Yes it’s a Intel driver, problem they don’t care to fix it. They are wrongly reacting to compat flags

Is a bug of KiCad 6.0.
I have installed 6.0 in Windows 11 machine. Same problem. Then, i install KiCad 5.1.4.
Version 5.1.4 works very well!! Same hardware and OS. Same cheap Intel Graphics Integrated card.
Please KiCad developers, correct this!!

Wise decision!! This is a bug in Kicad 6.

6.0.5 fixes some KiCad sensitivity to broken OpenGL drivers.
If 5.1.x works, 6.0.5 should work
If you do use 5.1.x, at least try 5.1.12, as 5.1.4 is ancient.

It would be nice if V6.0.5 fixed the graphic issue. But it didn’t.
But I retired my older PC and got an I7 desktop from Craigs List for $330. Now it renders 3D in V6

1 Like

Best solution if you have money. Not an option for me and lot of people.

Wrong. My installation says:
wxWidgets 3.1.5 Unicode and Boost 1.79.0
Platform:Windows 10 (build 22000), 64-bit edition,64 bit "
But really is installed in Windows 11.
And of course, OpenGL do not work in KiCad 6.0.5.
And why I should upgrade from 5.1.4 to 5.1.12? Maybe for introducing new issues? :slight_smile:

Not problem of Intel, because KiCad 5 uses same hardware OK.

Increments in the 3rd number are mostly bug fixes and an upgrade should always be safe.
For more details about versions see:

The release notes for each increment link to the corresponding gitlab page with milestones for that version.

KiCad 6.0.5 OpenGL works fine in Ubuntu 20.04.4 LTS in the same PC. This is a dual boot PC, Linux and Windows 11. Because of this, i insist is a bug in KiCad for Windows.

It could also be a bug in the video card drivers in Windows.

More than likely this. It is known older Intel chipset drivers on windows 10 do not report their gl capabilities correctly. Intel has no interest in fixing it as they usually only do a 3 year lifecycle on mobile chipset drivers. (That used to be their old excuse anyway)

Its a windows specific issue.

Is a bug introduced in KiCad 6. KiCad 5 works fine. :slight_smile:

If you see a bug manifest itself in KiCad, does not necessarily mean that the bug is in KiCad.
Different KiCad versions may use different parts of external libraries and drivers and this may show the bugs in those drivers in some KiCad versions, but not in others.

If it is known where the bugs in those external modules are then KiCad may be able to work around it by not using those parts at all, but it’s not always that simple.

1 Like

Wrong. In the same PC, Kicad 5 works fine.

I hope Kicad developpers let users a chance. Maybe a dialog box to let user choose between Kicad5 and Kicad6 graphic stuff.

V6 is using OpenGL differently, which is exposing the driver bug. Most PCs work just fine, so the OpenGL commands are OK.
I had a dodgy graphics card that caused Flightgear to draw artifacts on the screen.

This. @alejol, you keep repeating that it’s a KiCad bug because v5 worked fine. But the logic is what davidsrsb says. Newer KiCad does a bit different thing, but still the right thing.

This solved it for me: 3d board viewer not working because of OpenGL issues