KiCAD 6.0.5 Cannot draw anything in the symbol editor after putting a text item

First I want to say I respect all KiCAD developers, and I like KiCAD very much, I donate $200 in the KiCAD foundation donation march every year beginning.

After I upgraded to v6.0.5 there have been many issues, like I cannot grab a footprint by the pad’s center if the pad is too small. And today I met an even dumber problem.

The symbol editor will stop me creating any shapes if I put a text item. I couldn’t believe myself and I thought it was my laptop problem. Then I tried it on a Linux machine and it came with the same problem.

How to reproduce the problem

You can try yourself on the latest stable version, KiCAD 6.0.5, create a symbol and draw some shapes, everything seems fine right?

Then put a text item somewhere, and try to draw something again.

you simply can’t, lol.

This bug is also not a platform dependent issue, you can try it on Linux, MacOS and Windows.

I’m using a Mac (with Monterey) and Kicad 6.0.5

EDIT:

Yes, you’re correct. And, I have the same problem… thanks

@BlackCoffee you’re in the schematic editor, OP said symbol editor :slight_smile:

I can confirm. I think this is the same issue as Symbol Editor: Unable to create any graphic elements after selecting "Add pin" function (#11607) · Issues · KiCad / KiCad Source Code / kicad · GitLab

It should be fixed in upcoming 6.0.6

1 Like

It can be tried in “testing builds”, for Windows in Downloads | KiCad EDA.

2 Likes

It’s not just text items (or perhaps it’s any item containing text). Once you have placed a pin, the draw tool stops working.

A workaround is to do all your graphic drawing first, then add the pins. Takes a bit of planning/trial and error.

I’ve found that you if you save, quit and reload the symbol in the editor, it allows shape drawing.

Just adding observation:

New Symbol
Place Text
Draw Circle
Cursor pops to a consistent spot in window and can’t draw

However, it leaves a Tiny ‘Dot’ circle.

No doubt, it will be noticed/fixed but, just wanted to mention it in case it’s un-noticed…

Now, look at the Cursor. See the Dot?

It was fixed 3 weeks ago :slight_smile: