KiCad 6.0.10 tools freeze when launched (was OK yesterday)

Application: KiCad (64-bit)
Version: (6.0.10), release build
wxWidgets 3.2.1
libcurl/7.86.0-DEV Schannel zlib/1.2.13
Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
Date: Dec 19 2022 21:23:04
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.86.0-DEV
ngspice: 38
Compiler: Visual C++ 1929 without C++ ABI
Build settings:

NOTE: this is an upgrade from 6.0.1 but has the same “freeze” problem.

I have been using V6 (schematic entry and PCB design) for the past couple of weeks with no problems. I was last using last night. Today when I tried to open the schematic editor from the launcher the window appeared, with no contents, and the tool was frozen. Same problem when I tried to launch the PCB editor.

So I killed the frozen tool. I then cleared Windows “TEMP” folders. Re-lauched, no change.

I then searched around in user/AppData/Local and found the KiCad folder. Deleted it. Probably a bad idea, but a friend who had similar problems reported that this worked for him. Re-launched KiCad, then the schematic editor, immediate freeze again. The app was totally locked up. Had to kill.

Went direct to the install “bin” folder and double clicked on “pcbnew”. It launched OK. I loaded my last PCB, and it loaded correctly.

Downloaded V6.0.10 and installed. Re-ran KiCad, loaded a project, clicked on schematic editor, frozen (“Not Responding” - window goes a funny colour).

Killed and re-started. Tried loading a different project, but got the same “freeze” result.

Tried searching using google. Followed various links. Others have had similar problems, but didn’t bother to report if it was later fixed and it so how.

Would appreciate any advice.

Appdata/roaming rather than local has the KiCad folder with settings to delete to attempt a fix

It’s now working again.

I didn’t do anything different, and I didn’t delete any files. The PC wasn’t rebooted. No settings were changed. No software was installed and deleted. I didn’t even launch any other applications.

I’m baffled.

The only thing I can think of is that I normally click on the right hand side icon, and when it worked again for the first time I clicked on the icon beneath “Project Files” (left hand side). This could have been a coincidence.

After using KiCad without problems for the last week or two, I now have the same freeze problem when trying to launch the footprint editor. This time the schematic loads without problem.

Did it again yesterday.

What is really strange is that I have been using KiCad 6 recently with no problems. The PCBs which I designed using it recently arrived back from JLCPCB. I now need to assemble them, so I needed to view the schematic. Everytime I opened KiCad 6 and tried to open either the schematic or PCB, it froze (“not responding” message). I tried removing the folder AppData/Roaming/kicad but this made no difference.

Today after switching on the PC, I tried again. This time the schematic has appeared.


For lack of a better idea, maybe give the PC a good spring clean: clean up junk files, optimise the disk?

Appreciate the suggestion. PC is fairly new and high spec. There is plenty of disk space and free RAM. I do use tools to keep the PC relatively junk free. BTW I don’t think disk optimisation using 3rd party tools is really needed nowadays, so I’d rather leave the disk management to Windows.

I forgot to mention that I have a friend and he has suffered from the same freeze problem. He suggesting cleaning out the “kicad” folder in the AppData/Roaming area. I tried this, but upon re-starting KiCad it still froze. The next day (after a fresh power-up) all was OK again (but I needed to change some default settings, such as PCB trace colors).

As I mentioned for the past couple of months I have been using KiCad6 to design PCBs with no problems whatsoever, so it was a surprise when it happened.

While googling for an answer, I found my own thread (which I had forgotten about , how ironic!), but I also discovered that KiCad 7 has been released, so I will try installing that version.

Windows has its own disk optimisation tools now, no need for third party tools. You can even set then to run at quiet times.

Computer freezes can be due to hardware, particularly display hardware. Applications that push the graphics functions hard can trigger issues. Sometimes upgrading the drivers works. This sort of hard to replicate bug is quite frustrating.

Even on Linux in the past I had my display on a NUC form factor PC lock up occasionally. Then at some point after some X driver upgrade for the Intel video chipset it stopped happening.

How ironic.

I have just downloaded and installed KiCad7.

I opened the KiCad6 project I want to view, and immediately got a freeze “CH375–Schemtic Editor (Not Responding)”.

Oh dear, getting to the root cause of this is not going to be easy :frowning:

I just now clicked the X (close) icon and Windows asked if I wanted to re-start the app. I usually close the app, but this time allowed Windows to re-start, and I clicked on the schematic symbol and it loaded without problems.