KiCAD 6.0.0 Eeschema: components misalignment

First Schematics from scratch on KiCAD 6.0.0

here the misalignment. The grid is ok. But the resistors have issues as I see.
I got the same also with the Ground symbol and the resistor.

Urges a patch


Any idea how they got like that / steps to reproduce?

You can fix it with right click on misaligned symbol → Align Elements to Grid

I just imported them. That’s it. As I said: this is the first Schematics with KiCAD 6.0.0.
All the other ones are made with 5.1.12 and up there: never this issue

EDIT

i think the issue is on the resistor library, because till now, I didn’t get the same issue with other components (Im’ drafting a schematic in this moment)

Is it repeatable if you reimport the same v5 schematic? If so, it would be really good to get a bug report for this.

When I import from 5.1.12 not any issue.
I said it right above your comment.
The issue is only when I start from scratch on 6.0.0

Does this mean you started a new project in 6?

From what library are the resistors: Kicad device or personal?

Have you altered any grid settings when starting?

1 Like

yes as I said: starting from scratch on 6.0.0
Yes library is standard kiCAD
Didn’t alter anything.

here into the animated GIF what’s occurring.
Everything is STANDARD (I said this several times now)

@jmk note the misalignment on the second animated GIF. Always same component

KiCAD_placementError

I copy and paste the above resistance. It’s the same component, it’s imported from the same library. But then the aliment is right.
I’m not sure is the library then. There is something strange occurring.
KiCAD_placementError2

This problem occurs due to your copy-past action.
copy/past involves CTRL-C/CTRL-V.
The CTRL-key alone is the “ignore grid”-modifier key. So if you have the CTRL-key still pressed while you click the left mouse-button to fixate the pasted symbol this pasted symbol is not align to the grid. It helps to slow down your working-speed.

4 Likes

Ah!!! It means that a small delay on releasing the CTRL can cause this issue?
Isn’t that better to change the mouse modifier 'ignore-grid"? :roll_eyes:

Ah!!! It means that a small delay on releasing the CTRL can cause this issue?

Yes.

Isn’t that better to change the mouse modifier 'ignore-grid"? :roll_eyes:

with version v6 the modifier-keys are fixed.
If I remember correctly there is a feature-request for v7 to allow the users to change the modifyer-keys, so

1 Like

Well let’s hope do not wait 1 year for the version 7 then :-/

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.