KiCad 5 RC3 creates invisible files & folders in Windows 10


I installed KiCad 5 RC3 x64 in Windows 10 after uninstalling KiCad 4 and generally it is running very nicely.

When I create a new project using File>New>Project the new folder and files created are invisible to Windows Explorer. I can create the schematic and PCB as normal however I can only see the files when KiCad is running using Browse>Open File.

For now I am avoiding this option but I am concerned about possible problems for the future. If anyone knows what is happeneing and how to overcome it I am keen to hear.



Did you install it as administrator or some other user?


Followup to @davidsrsb’s question. Are you creating and saving your project folder in what is normally a hidden folder in Windows?


Thanks for the prompt responses.

I only have a single user for myself and I am an administrator. I usually install for all users if that is an option. I don’t think that option was offered on this install.

I don’t use any hidden folders for my installations or work files.

I will try installing a copy on my laptop and see if it does the same.


You have to be an administrator to install KiCad.
I meant did you “Run as administrator” to open the installer, you should not do that.
What is your project folder directory?


I didn’t install it the first time using “run as administrator” but I have reinstalled it using that option. Didn’t make any difference.

I installed it on my laptop and everything works fine. No hidden files.

I have synchronised my project folders on the two computers so there should be no problems there. One computer generates hidden files the other doesn’t.

Both are Lenovo machines with i7 CPU. The desktop runs Windows 10 Pro the laptop Windows 10 Home. Both have the latest updates to build 17134. The file structures on both machines are similar.

Another anomoly I have noticed with the desktop is in AppData>Roaming>kicad. Using Windows Explorer I can see fp-lib-table 2018/06/24 this is the table from the original install. If I use Kicad>browse>local file and look in AppData>Roaming>kicad I see fp-lib-table 2018/07/04. This contains some additions I made and is the working file. Curioser and curioser.

Anyway I think the best option is to delete all the files I have created which are only visible using KiCad then uninstall everything, clean the registry and try again. I’ll be back.


You are saving to the VirtualStore which in Windows is virtually mapped and pretends to be C:\Program Files when you aren’t running the program as admin (this is a Window security feature and working as intended). and saving files in C:\Program Files and C:\Program Data. So inside the program, you’ll see a fake C:\Program Files among other things but outside in explorer you won’t find it in that exact spot. But, please don’t save work items in those folders, its generally bad practice, and its best to use your user folder, i.e. Documents, Desktop or even create a new folder in your user root C:\Users\%USERNAME%\.

To find your files and move them somewhere else go into

C:\Users%USERNAME%\AppData\Local\VirtualStore then go into the correct Program Files (x86) or non 86. Find the kicad folder. Take the data out and delete the kicad folder in virtual store so that it stops mapping it in the file dialogs.

And if you somehow got unlucky enough with permission muckery, there may even be a C:\Users\%USERNAME%\AppData\Local\Users\%USERNAME%\AppData\Local\KiCad

which would explain the fp-lib-table behavior you see.

You will be forced to escalate to admin to run the installer regardless. Program Files always requires admin to write to and KiCad does not do user level installs (unfortunately there are a few issues in the program and not just installer that prevent it)


Thank you for the help, I’ve learnt something new. I haven’t come across VirtualStore before.

After I deleted all the files I created in the VirtualStore area I uninstalled KiCad, deleted the Kicad files in AppData, cleaned the registry and reinstalled everthing including the environment variables. It all looks good now and my new files are being created in the right place. Just have to change the environment variables back to my normal settings and I can get on with learning what has changed from V4. I must admit I like what I have seen so far.


I haven’t been able to locate KiCad 5 rc3 for windows 10. Did you compile your from the source?



KiCad v5 RC3 has still not been released, despite the enthusiasm of many posters :slight_smile:

When people talk about “v5 RC3” they actually mean “the latest nightly development build” which comes with caveats.


On the KiCad website, Nightly builds, RC3 is the 2nd July r10601 build, compiled after the RC3 tag was applied…
You are better with the 7th July r10603, which fixes two more rare but severe bugs.


I have downloaded a couple of nightly builds over the last couple of months. Usually they display the build number in the header.

RC3 has been listed at as “release registered” on 2018-06-30 by Wayne Stambaugh and a source archive is available for download. I’m not into the politics of software development but that smells pretty much like a release to me.

I downloaded the first nightly build after the release date kicad-r10601.520c6116f-x86_64.exe and the header reads KiCad (5.0.0-RC3-dev). This is the version I am currently using.


Just noticed the last post from davidsrsb about the r10606 build. Thanks. I might give that a try.


Sorry. Typo. R1060103


Nightly builds are not releases, they are development snapshots. If you use a nightly build, you do so at your own risk

Released versions of KiCad appear here


Back to my original problem. I found all the “invisible” files in a folder called VTRoot\HardDiskVolume2 along with lots of bits and pieces from other programs. Looks like another virtual storage area in Windows.


VTRoot comes from Comodo Internet Security shenanigans which instead of allowing the OS to enact its centralized security operations, decides to do its own virtual folder mapping and effectively make a giant mess if you ever uninstall it (which is good for them to discourage you from doing so)


Comodo makes only its work using a Windows functionality to protect your PC.
To circumvent the protection of a software, open Comodo and click on the “Blocked applications” button in the Firewall section.
In the “Applications to unblock” windows, select any line containing the word "KiCad"by validating their checkbox, click on the “Unblock” button in the upper bar.
Thats all folks.