KiCad 5 Framebuffer Error & Question


#1

Hi Guys,
I’m a new member of this forum. I installed KiCad V.5 on my Laptop with “Nvidia GEFORCE 940MX” Graphic Interface.

When I associate the footprint to a schematic symbol during schematic design I alert the follow Windows Error: "Error: switching framebuffer: invalid framebuffer operation". I don’t find anything about this message related to KiCad.

I understand that probably depend from Graphic Interface and OpenGL, but despite the Graphing interface driver update I’m continuing to have the same error message.

Final question. I often work without an internet connection. How can I locally save the libraries?

Can you help me, please?
Thank you.

Marco


#2

A correct kicad 5 setup should come with local libs. You might want to take a look at this: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

Maybe this is also a good read for you How can i install a specific version of the footprint library?


#3

Thank you Rene_Poschl. This problem is solved.
Any suggestion for the error?

Many thanks.
Marco


#4

I too am getting a “Error: switching framebuffer: invalid framebuffer operation” when trying to associate a footprint to a symbol. Screen shot of the error attached.

I’m on Windows 10, Kicad 5.0.1-rc2. The error happens using integrated graphics and GeForce GTX 860M.

Any suggestions? Should I report it as a bug?

Thanks,

Iain


#5

Changing my NVIDIA Control Panel Global Settings ‘Preferred graphics processor:’ to Auto-Select appears to have fixed this. Something has, anyway.

Iain