KiCad 5.99 Could not use OpenGL (macOS)

Hi all,

Not sure if this is the right place to report this. I am not able to get into the report bug link in KiCad about.

I am just trying the new 5.99 Nightly. Attaching version info.

Sometimes ( can not find any pattern ) when working on a layout I am getting an error message.
“Could not use OpenGL
error: setting draw buffer: invalid operation”
After that I should force quit KiCad because message appears immediately after I hit OK.

macOS 11.2.1

Application: KiCad

Version: (5.99.0-9005-g11af24b592), release build

Libraries:
wxWidgets 3.0.4
libcurl/7.64.1 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.41.0

Platform: macOS Version 10.16 (Build 20D74), 64 bit, Little endian, wxMac

Build Info:
Date: Feb 11 2021 19:41:47
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.54.0
ngspice: 31
Compiler: Clang 10.0.1 with C++ ABI 1002

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

The same happened today with my older kicad version. It seems like I am not abled to work on layout anymore. I am getting white screen in pcbnew if try to open any of my projects.

Any ideas?

Thanks in advance!

Application: KiCad
Version: (5.1.9-0-10_14), release build
Libraries:
wxWidgets 3.0.4
libcurl/7.64.1 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.41.0
Platform: macOS Version 10.16 (Build 20D74), 64 bit, Little endian, wxMac
Build Info:
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
Boost: 1.75.0
OpenCASCADE Technology: 7.5.0
Curl: 7.54.0
Compiler: Clang 10.0.1 with C++ ABI 1002

Build settings:
USE_WX_GRAPHICS_CONTEXT=ON
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=OFF
KICAD_USE_OCC=ON
KICAD_SPICE=ON

What canvas settings are you using? You should have “Modern Accellerated” set . Try pressing Fn11. You might still need to adjust the antialiasing settings for optimal rendering.

Mmm I accidentally deleted my configs and now it is working, so it is possible that you were right.

I am not sure how it happened, just woke up my computer and the message was there.

Thanks a lot for your replay!

Today I got a system crash report for 5.99

Not sure if is possible that the program crashes when using pcbnew on my second monitor it is a long shot but can not find any pattern.

I am attaching my system crash report, hope this will help to someone with more knowledge of the KiCad structure.

I will try to build KiCad from source on my machine as soon as I can.

Thanks a lot!
kicad_crash.txt (77.1 KB)

12  _eeschema.kiface              	0x0000000110b04044 COROUTINE<int, TOOL_EVENT const&>::callerStub(long) + 52

COROUTINE means probably parallelism which is usually difficult to debug and may be hw/driver/sw/OS version etc. specific. It’s even possible (although improbable) that nobody else ever runs into this.

I suggest you go to https://gitlab.com/kicad/code/kicad/-/issues and report this properly. (The About dialog’s button is just a shortcut which leads to the issue tracker with some prefilled info.)

coroutines aren’t true parallelism. They are faux parallelism sharing the same thread as the gui that doesn’t require any special hardware. It’s no different than context switching on a rtos in a micro.

A fault ending in the coroutine just means the stack switch has confused the call tree shown potentially.

Got it.

Thank’s again!