KiCAD 5.1.x - How to use Net Classes? (Nets won't load)

Hi All,
The new (in 5.1) Board Setup dialog box is not working as I would expect. Board Setup > Design Rules > Net Classes - I’ve defined some wider traces for my power & ground nets. Now I’d like to assign some nets to use these wider traces. But the dialog does not show any of my nets, and won’t import them either.


  1. Why won’t my nets load into this dialog?
  2. Is there a more accepted why I should be doing this?


1 Like

The board setup dialog should have all your nets listed in the "Net* area, like so:

The most logical explanation is that you do not have any nets in Pcbnew yet.
Have you imported the Footprints and Netlist from Eeschema?
Do you have the Footprints and ratsnest in Pcbnew?

The quickest way to do this is to go back to Eeschema and press [ F8].


Thanks Paul. Yes, I’ve already imported my schematic’s netlist & footprints together. Then I updated it once, b/c I needed to change a footprint. Here’s the PCB in progress…

This is weird.
You have a PCB with components and with the thin white ratsnest lines, which can only appear if you have a netlist in Pcbnew.
And yet, there are no nets in the “Net” box in Pcbnew / File / Board Setup / Design Rules / Net Classes

I’m curious now to have a look at the board to try to figure out what’s going on. Can you zip the whole project folder and upload it somewhere on the 'net? As a new member you unfortunately have not “earned” the right yet to upload files directly to this forum (At least I think so).

Also: if this is a bug your full KiCad version is wanted. It’s the text you see wen you
Kicad / Help / About KiCad / [ Copy Version Info ] / [ OK ] and then paste it here. It’s about 20 lines of text.

Thanks for the interest Paul. It does feel like a bug.

Project zip file:

Application: Pcbnew
Version: (5.1.5-0-10_14), release build
    wxWidgets 3.0.4
    libcurl/7.54.0 LibreSSL/2.6.5 zlib/1.2.11 nghttp2/1.24.1
Platform: Mac OS X (Darwin 18.7.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
    Boost: 1.69.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.54.0
    Compiler: Clang 9.0.0 with C++ ABI 1002

Build settings:

Found your zipped project, extracted it (Ignored the __MACOSX thingie) and opened it. with KiCad’s project manager.

(I just started this reply to post the screenshot. I will do multiple edits and commits as I go along. So try to be a bit patient).

First weird thing when opening the schematic is:

Schematic looks like a normal schematic.
PCB looks like your screenshot.
Pcbnew / File / Board Setup / Design Rules / Net Classes looks like it should on my system: I see all the nets in the Net box:

Then I go back to the schematic, and update the board with [F8]. It complains about missing footprints for switches.
All the red texts in:

I do not know what your intention is with these components, but if the components are not on the PCB, then they also are not in the netlist.

On your schematic I see that some components are placed off-grid.

It is very strongly advised to always place components on a “50” (or multiple thereof) grid. It’s a sort of long standing and known KiCad bug that component pins endpoints have to lineup with the green line ends and there is no snap (yet). Keeping all components on a “50” grid is an easy workaround all beginners have to learn untill there is a real “snap” function in Eeschema. In your particular case the connections do seem to be reflected in the netlist, so it’s not the problem you try to adres here.

In the Net Classes I can see you have assigned 3 nets to “Power”, by selecting that net in the "Net class filter:

Most of the other nets are in the “Signal” net class. So apparently you have managed to change this in the past.

I’ve renamed your project folder, and saved the file in my KiCad V5.1.5 version. Then also removed the “take1.kicad_pcb” and some backup files, and then zipped the whole directory: (229.7 KB)

Does this version behave any differntly on your PC? Can you work with the net classes now? Does anything happen when you click on the buttons on the Board Setup window?

Edit yet again:
I’ve had a little bit closer look at your schematic.
The missing footprints are obviously intentional.
If you put an # in front of the reference field, you tell KiCad to exclude these components from the BOM and the PCB. Like this:

1 Like

Hi Paul,
Thanks for the analysis. Shame on me for not having tried this: I killed KiCAD, restarted it, and now the nets are appearing in the Board Settings as expected. That would appear to be a bug, but one that has an easy work-around.

(Correct, those ~6 unconnected components are intentional; this is a guitar pedal, and those parts will be mounted on the enclosure).

#BOM I’d read about this trick. If I understand the #feature you describe, it may not be right for me, because I do want the parts on the BOM, so I remember to purchase them. My hope is that I can just delete them from the PCB (in fact, they had no footprints, so they never appeared in PCBnew… so I think I’m all set).

Thanks again for you interest in my problem!

1 Like

Killed KiCad ??? Normal close did not work?
If you can find a way to reliably trigger this bug, then the developers of KiCad are very interested in this. Serious bugs are high on their priority list.

If you can not recreate the bug, then it may as well have been a misalignment of some planets in a galaxy far, far away. confused0024

Sorry, I meant “closed KiCAD using the Quit KiCAD menu item”, and all worked fine upon reload. I be on the watchout for actions leading up to the bug, if it reoccurs.

Thanks again!

“Me too”? I have followed along in this thread, and I too have many nets, all showing up in the net view, however, under board setup, in Net Class Memberships, no nets appear at all, no matter what I select or how. I am on KiCad (5.1.5)-3

Can you upload the (zipped) project here?

(You may need to spend some time reading some topic in this forum to get priviledges to do that.)

The following work-around worked for me: close the KiCAD app, and restart the app. Then, my Nets showed up in the Net Class Membership window.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.