Kicad 5.1 to 6 project migration problem (schematic)

I had a good experience with opening projects in 5.1 before but I have one project where the schematic just disappeares when opened in KiCad 6. Also hierearchical sheets won’t appear in the project files.
The PCB layout looks just fine.

Any idea on where to start troubleshooting?

I would be willing to share the project with anybody interested in trying open it (it’s going to be open source at some point anyways) …i just don’t want to post it publicly at the moment.

You can send it to me in a Private Message.

1 Like

It seems to open normally. First you should check if your situation matches with SOLVED. Just upgraded to 6.0.2 - My 5.1 schematics are no longer visible. Just a gray sheet - #4 by eelik.

1 Like

Yes, this looks like the issue I ran into.
Short term solution: Open the schematic editor and go to:
Preferences → Preferences → Display Options and select “Fallback Graphics”.
Longer term solution: update your graphic drivers (might not always work).

1 Like

Thank’s for trying! -interesting that it seemed to open normally on your machine. did you open the old .sch file directly or the project file?
It was definitely not the graphics problem - I always saw the graphics frame of an empty sheet.

I did find a solution though. I deleted the .kicad_sch file in my folder, after that kicad showed me the old .sch schematic file again in the project files which opened normally and works as expected after saving in the new .kicad_sch format.

looking at the deleted file, it was definitely empty (should have done that before asking for help, sorry):

(kicad_sch (version 20210621) (generator eeschema)
  (paper "A4")

I can not completely rule out the possibillity that I have opened the file with a 5.99 version a while ago and it messed something up in the conversion process…anyways…maybe this is at least hepful for somebody who has the same problem.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.