KiCad 5.1.8 PCBNew and Footprint editor crashes

I have recently installed KiCad 5.1.8 on Win 7 and I am experiencing crashes in a couple of scenarios that are likely all due to the same cause. I previously had 4.0.7 installed and it was very stable with no issues at all, one reason why I was reluctant to upgrade before now.

If I open KiCad and then open the footprint editor and select any footprint it will display the footprint. If I place the cursor over any item in the footprint and press ‘E’ the appropriate dialog opens. If I click the “Default pad properties” toolbar button the “Pad properties” dialog opens but if I click the “Footprint properties” toolbar button the Footprint Editor crashes.

If I open a board layout and place the cursor over a footprint and press ‘E’ PCBNew will crash. If the cursor is over any footprint text then the “Footprint Text Properties” dialog will open. If the cursor is just over the footprint or a pad and I press ‘E’ PCBNew will crash.

Otherwise everything seems to be okay, both schematic and PCB layout display correctly etc.

My graphics card recently failed so I am temporarily using one that does not support the accelerated canvas, if I do try to use it KiCad crashes.

Is there a setting that I am missing somewhere?

Additional info:
If in PCBNew I left click on a footprint pad the pad is highlighted and pressing ‘E’ opens the “Pad Properties” dialog. If I left click on the footprint so that the entire footprint is highlighted pressing ‘E’ causes PCBNew to crash.

I tried all your suggestions in V5.1.8 but could not reproduce the error.
They’re also pretty normal operations and (of course) should just work.

When troubleshooting, always post the Full KiCad version from:
Help / About KiCad / Copy Version Info

Did this error start after installing V5.1.8, or after swapping the video card?
I’m guessing here, I do not know how robust installing on Windoze is (I use Linux) Maybe there is a possibility you installed from a corrupted download?

Hi Paul,

Thanks for your attempt to reproduce. I had been using 4.0.7 with this video card for a while without issue before installing 5.1.8. When I noticed the issue I uninstalled KiCad and then reinstalled it. Initially Eeschema would crash when I tried to launch it but that was resolved by editing the configuration file and adding canvas_type=2.

Application: KiCad
Version: (5.1.8)-1, release build
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:

I have not been able to reproduce this on 5.1.8 64 bit on Windows 10

edit So canvas_type=2 is a solution?

canvas_type=2 only resolved eeschema crashing when I tried to launch it. I also added canvas_type=2 to the pcbnew config file and it stopped prompting me to use graphics acceleration. But it still crashes when I try to view the footprint properties either in pcbnew or the footprint editor. The crash occurs regardless of which project I have open or which footprint I use.

In case it is helpful for anyone here is the exception info and call stack:

Unhandled exception at 0x000000005AAE06EE (atio6axx.dll) in kicad.exe: 0xC0000005: Access violation reading location 0x000000000000118B. occurred


Hmm, atio6axx.dll is part of the AMD Catalyst drivers. Have you updated your graphics driver?

I tried, but Windows claims “The best driver for your device is already installed”.

Maybe canvastype=2 for the footprint editor too? And the Gerber viewer if already at it.

The footprint editor does not seem to have it’s own configuration file, I have tried adding Canvas_Type=2 to the “kicad” configuration file and the “kicad_common” configuration file with no change. Gerber Viewer runs without any issues.

You can enforce driver update even if windows claims it has the best driver.

Three options for windows:

  1. Have disk method - in case you know what you are doing - if not, continue to 2.
  2. Some setup files have command switches i.e. /overwrite which forces installing new drivers.
  3. In case no command switches available, uninstall the drivers and install new one.

Backup the configuration, then delete it and run Kicad. This will make sure that you are starting with default (safe) configuration.

Tried that. Footprint editor still crashes. Eeschema crashes on startup and because it crashes it never writes it’s config file so I can’t edit it and add canvas_type=2. Once I copy the old eeschema config file back I can then run Eschema. PCBNew still crashes when pressing ‘E’ with the cursor over a non-pad/text area of a footprint.

Was the dead graphics card AMD?
What are you using now?

Download the most up to date driver package from AMD directly

Windows Update will not use the latest drivers on older cards that AMD may not care to submit to Microsoft for those older cards.

You’re in for a long haul. It looks like you’re the only one experiencing this and it can be that you’ve got a broken Windows configuration. Can you install gdb and run KiCad with gdb. You’ll at least find out where it crashes. And if it crashes in the system code it is likely that this is not a KiCad issue. I had such an issue and the only thing that helped was a Windows reinstall

drmingw is an easier solution for crashes in programs compiled with mingw/gcc. But I doubt it helps at all if the issue is in OpenGL/drivers.

1 Like

Downloaded and installed most recent driver from AMD, still crashes.

Current video card ATI FireGL V7200 not much but it was all I had laying around that supported a dual monitor setup.
Card that died was a Radeon HD 4870.

Information from Catalyst:

Provider ATI Technologies Inc.
2D Driver Version
2D Driver File Path Not Available
Direct3D Version
OpenGL Version Not Available
Catalyst™ Control Center Version 2009.0211.2225.40219

Yea that’s straight up a 15 year old card…it’s best to say it most likely has driver bugs that are never going to be fixed nor anything we can do in KiCad to handle it.
It does appear AMD dropped driver support back in 2009.


You are right, the footprint editor and pcbNew share the same configuration file. Do you have the same effects with v5.1.7? or v5.1.6?

v5.1.7 has been for me pretty stable, v5.1.6 has a annoying bug when connecting tracks, but it would be informative to see if is a new video driver Problem or has been present for a while.

In this regard, I did some test yesterday with v5.1.8 on my PC and I was very surprised that the accelerated mode worked, it had never worked before on that PC, so maybe something did change on last 2 or 3 versions.