KiCad 5.1.7 in Linux don’t print hierarchical sheets

I have a schema with a “main” sheet and two hierarchical sheets. When I try to print if I choose “all pages” it print the first (the main one) then a blank sheet.
If I choose “page 2 only” it print a blank sheet. If I choose “page 3 only” no print at all.
This happens in two different Linux distributions: openSuse 15.2 and OpenMandriva Lx 4.1 then I think is KiCad bug.
Plotting in pdf give three pages as expected.

I could not reproduce it in Win10 with Kicad 5.1.7 but my options look like that when printing:


I’ve the same dialog window. But have you tried to print a schematic with one main sheet and two hierarchical sheets? What you get?

If you want to try printing a single page you can choose a printer and from printer dialog chose which page to print.

I just tried and worked fine for me. 5.1.7 on ubuntu 18.04.

Yeah i did, one main sheet with 3 subsheets, it worked as expected

Really strange. On Linux Mint 19.3 (that should based on Ubuntu 18.04.3) I simply cannot print. When I print pc seems working a bit then I get an error message like “Printing canceled” and I don’t find anything in printing queue.

Please try to print page 2 o page 3 only. When I try I get simply nothing.

Are you printing to physical printer? What happens if you print to file? Do you get a complete PDF? If so maybe there’s a problem with your printer driver (which includes the PDF to printer language converter)? Or maybe the converted printer language output is too complex for the printer and it gave up and aborted the job. What printer is it?

Can you share your schematic? Or maybe reduce it to the simplest example that doesn’t give away any of your secrets.

I did (print directly to a PDF) and worked fine printing pages 2-3 of my multi sheet schematic.

Share your project.

and more characters

After all comments and suggestions I did more try and I’m almost sure that the problem is in my schematic that you’ll find attached (90.3 KB) .
This because:

  1. I created a very simple new hierarchical schematic that behave normally for me too
  2. printing to file my schematic give main sheet and one blank page, as in real printing (you’ll find it in the “output.pdf” file)

I can’t confirm if the problem is in your schematic or not. I have tried with an A4 page instead of “user” and the problem is still there.

Anyway I do recommend using plot instead of print. Plot to pdf and then printing from a pdf viewer has historically been safer in KiCad than the Print tool.

I loaded your schematic and can confirm that if printing, the 2nd page is blank and the 3rd page missing. Interesting though that the preview shows all pages.

Perhaps you should submit a bug report with the input files you have. Maybe you have a weird symbol that tickles the bug.

I just printed your project (to pdf) just fine.

So much has been changed in v5.99 versus 5.1, especially in eeschema, that the bug may have disappeared accidentally. It’s worth reporting for 5.1.

I confirm, changing that line “print to pdf” option works as expected.
But I can’t ever imagine how you found the problem. I never thinked to it. Can you explain?

Binary tree search is magic :slight_smile:

I deleted everything in your hierachical sheets, when that fixed it I went back and deleted only half. Rinse and repeat.

You could apply the same process to nightly commits (git bisect) to determine where exactly the problem was fixed.

1 Like

When you don’t know divide the problem in half! Simple and clever.
I did the same for other problems in CAD.

Btw: ancient Romans used the same technique called “divide et impera”, in english “divide and conquer”. :wink:

Reported the bug hoping it will be clear.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.