Kicad 5.1.6 crash on start - help

HI, Running on High Sierra , 5.1.6 eschema was running fine. ( I have a whole project done ) Then suddenly eschema crashes ( spinning wheel ) , I reinstalled 5.1.6 , but still even if I create a new blank project , Eeschema open up a blank sheet with a title outline and crashes ( I’m running from the project manager )
pcbnew is running fine

haven’t a clue what to do next

PS: I reinstalled the applications and tried right click and " open in a new " tab " and tried schema directly , it started displayed a blank title and crashes. PCBNew runs fine


Update, cleared all hidden files ( Kicad files are everywhere on the Mac ) , rebooted fresh download , eschema is working

phew, thats scary, no idea what happened though

1 Like

The KiCad preferences are in ~/Library/Preferences/kicad on macOS. If you are ever in this situation again, it is easy to simply rename the preference file to something else like eeschema_old and then relaunch the application. A default preference file will be regenerated. Comparing the two files might give a clue as to what went wrong.

1 Like

Thanks , good to know , the dependence on one tool for this type of cad leaves you feeling vulnerable

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.