Kicad 5.1.5 on Raspberry pi


I actually use kicad 5.1.5 under Ubuntu 18.04 and I work more and more with the raspberri pi 4 with raspbian (buster).
Unfortunately, the actual version of kicad is :

$ sudo apt list -a kicad
Listing… Done
kicad/testing,now 5.1.4+dfsg1-1~bpo10+1 armhf [installed]
kicad/stable 5.0.2+dfsg1-1 armhf

I’m trying to find a way because on the 5.1.5 announcement, upgrade from 5.1.4 to 5.1.5 is strongly recommended :
But I have to say that the version 5.1.4 seams to work fine on RPI after some test

Did I miss something in the file /etc/apt/sources.list?
The actual content:
deb buster main contrib non-free rpi

I will not use bullseye instead of buster as the kicad version will switch to 5.1.6 that is testing actually

Many thanks

It wouldn’t be from the raspbian repo. Have you added the jsrenaud repo for Ubuntu to sources.list as explained in the release notes you linked to? 5.1.5 is available, see

Raspian isn’t Ubuntu or Debian, so this advice isn’t very smart.

As this question was also sent to the pkg-electronic-devel list on Debian I will simply give the same answer.
Any updating of the packages within Raspian needs to be done by this distro itself. Or people try to switch over to a native Debian on Raspberry devices. The Debian Wiki has some information how this can be done. Then also the backports archive is usable.

I misread OP’s wording. He seemed to imply he was using Ubuntu on RPi (yes it does exist), but now I see that he meant that he was using Ubuntu on his PC and wanted to also run it on RPi, and mention of Ubuntu was a red herring.

However, you are mistaken in one respect. Raspbian is mostly Debian with just a special kernel and the Pixel desktop. The package management tools in Raspbian are the same as for Debian, and most of the packages come directly from Debian. Kicad 5.1.5 is in the Debian repos. Without actually trying it, or having a RPi4 to try it, I venture to say that it is possible to install Kicad from the Debian repos without “switching”. Not sure how well it would work with the RPi4 resources.

As you say, mostly! But organizationally these are two completely different projects! There is nothing Debian can do about updating package versions within the Raspian universe, and that’s the point here. This can only be done by Raspian.

1 Like


Thanks to both of you for your assistance. And your are both right : raspbian use the debian package, but the raspbian team have to compile them from source for ARM that is a RISC processor. Furthermore, the raspbian team made a hard work to make a patch for the GPU (OpenGL driver).

For the backport, I had difficulty to find source.

I tried to test 5.1.6 from the bullseye repo (just for the fun I have to said because 5.1.6 is testing)

#deb bullseye main contrib non-free rpi

I updated only kicad and dependencies (new version of python mainly) and saw kicad 5.1.6 running on RPI. But then LibreOffice was broken because of python. I had to manually remove packages (python and kicad) and reinstall them from buster repo.

I tried to upgade all the system to bullseye, but the system hade big problem with the windows manager.

In summary :

When I updated kicad from 5.0.4 to 5.1.4 on the RPI (a week ago), the improvement was significant : implementation of the modern toolset (accelerated) for pcbnew (I noticed a real improvement in speed) and the cursor bug was solved.

I can work on my last design that is a 300 components size. Pcbnew run fast on RPI if the size of the windows remain lower than full screen on a 4k display. (this is not a problem for me as I use half screen for pcbnew and half screen for eeschema on a 43” screen)

I think I can continue the work with kicad 5.1.5 on Ubuntu and 5.1.4 on Raspberry (Both machine are synchronized with syncthing). This little difference of version should not be a source of problem as the files format remain the same.

I think the kicad team made an amazing work! And this is for me the occasion to thanks them : I made professional design in university with this software. Kicad do the job for complex design with a fast learning curve (compared to the other heavy commercial soft.)

When the bullseye raspbian will be stable, I will be able to use 5.1.6 under RPI. This is why if 5.1.5 isn’t yet on RPI, compile from the source would be a wast of time for the kicad team as they would prefer focus effort on the new 5.1.6 for all platform (I guess)

IIRC the reasons Raspbian had to have a separate distro were: special kernels and bootloader with blobs, the Pixel desktop, and also that the RPi1s needed armel binaries because the ARM6 processor didn’t do FP. From either 2B or 3 onwards, the architecture is armhf so packages for that architecture should work. so that last reason can be taken off the list of differences.

As for OpenGL, that’s understandable as it’s GPU dependent, but if the ABI is the same, the callers to the OpenGL library shouldn’t notice.

So it might just be possible to use the Debian buster backports. There is still the Python 2/3 issue for LibreOffice, maybe.

Anyway take this with a grain of salt as it comes from someone who last bought a RPi2. If you do decide to play with buster backports and it breaks, you get to keep all the pieces. :wink:

Thanks for theses precisions.
I added

deb [trusted=yes] buster-backports main contrib non-free

after an update :

sudo apt list -a kicad
Listing… Done
kicad/buster-backports 5.1.5+dfsg1-2~bpo10+1 armhf
kicad/testing,now 5.1.4+dfsg1-1~bpo10+1 armhf [installed]
kicad/stable 5.0.2+dfsg1-1 armhf

sudo apt-get install kicad=5.1.5+dfsg1-2~bpo10+1

I get an error that stop installation:

Err:4 buster/main armhf python3-wxgtk4.0 armhf 4.0.4+dfsg-2
Cannot initiate the connection to
And apt sayed to :
The following additional packages will be installed:
python3-olefile python3-pil python3-sip python3-six python3-wxgtk4.0

Mayebe a possible source of problem like I hade with libreoffice as you said

Anyway : interesting to know it’s possible to add debian port when need to test some missing package.

I think that’s a different kind of error. Your deb line appears to be out of date because that domain name disappeared. I think this page has the correct information:

which states

Yeah, my memory is going, but I’m sure that at some point I have installed packages that didn’t exist in the Raspbian repo from the Debian repos, but then those were small programs. Larger programs would be more prone to issues.

It works! So amazing

In /etc/apt/sources.list

deb buster main contrib non-free
deb-src buster main contrib non-free
deb [trusted=yes] buster-backports main contrib non-free

then update and sudo apt-get install kicad=5.1.5+dfsg1-2~bpo10+1
no problem with libreoffice.
thanks : you solve my issue

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.