Kicad 5.1.5 on labtop

Hello,
I use KiCad (version 5.1.5) on two desktop computers and I am very satisfied. Everything runs smoothly.
Now I tried to install KiCad on a labtop. (eMachines Pentium dual core T4500, 2,3 GHz, 4 GByte Ram). The installation ran without errors, but after the start I can not start the schematic editor. The program hangs. The footprint editor works without problems.

What OS are you using? 5.1.5 is a little old and upgrading may fix your problem. Start there.

I use WIN10 as well as on the other PCs on which KiCad is installed.
There everything runs fine, only on the labtop the schematic editor and (!)
the board layout freezes after startup.
Thanks for the answer

64 or 32 bit?
Have you tried changing graphics mode to the Modern Toolset (fallback) emulated OpenGL mode with F12. There are broken OpenGL drivers out there

The operating system is WIN10 64 bit. I can not change the graphics mode with F12, because immediately after opening eeschema the program freezes and I get the error message “no response”.
In german language “kicad.exe reagiert nicht”
I have already tried installing KiCad in an alternate directory and/or running as administrator. No attempt brought an improvement.

Hello,

at home I am using Linux but at work I needed a “No-Install-KiCad” for Win.

The people here gave me the good hint to simply unzip the KiCad Install EXE and this works perfectly.

Maybe you should try this to find out if your problem is related to the KiCad Version OR to the Installation OR to your graphics equipment !?

Please don’t do that, KiCad is designed to be run as regular user and you will end up with locked files

1 Like

Hello,
the problem is solved. With version 5.1.5_1 (64 bit) the problems occurred. With version 5.1.9_1 (64 bit) the problems are solved. Yesterday a friend of mine reported exactly the same problem (eESchema does not work). For him, the problem occurred immediately after the last WIN 10 update. Maybe this hint is helpful.
Thanks again for the answers.

4 Likes