Kicad 5.01- Installation- can't locate libraries


#1

Hi,
Looking forward to using Kicad. Downloaded Kicad (kicad-unified-5.0.1.dmg) for Mac (Mojave 10.14.2). From the installer screen (see photo) did 2 step installation i.e. Dragged “KiCad” --> Applications then “kicad” --> ‘Applications Support’. Both steps had no problems. My understanding is the Application Support includes the KiCad symbol libraries.
Kicad Launched OK. Created first project. Lauched EEschema but can’t add any parts. Brings up empty symbol library dialogs.

Have read a couple closed Kicad forum topics, but still can’t make any sense of this. i.e. can’t locate the libraries that were installed anywhere that I have looked. The installation doesn’t say where they are being installed and browsing everywhere I can think of.
Please help,
Thanks


#2

same problem as well


#3

Are you under linux? I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled)

Was kicad 4 or a pre version 5 nightly ever installed on the same system? I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

And in general regarding kicad version 5 library management: Library management in KiCad version 5


#4

I have fixed it

for MAC: erase the preferences file otherwise kicad want to use the old Library paths nd thats wount work

for Windows: look to your documents folder and erase all kicad files before you install v5 and clear your registry


#5

Hi Rene,
Thanks for the excellent advice. What worked for me was going to the link you provided, Library management in KiCad version 5. I backed up the files in /Users/username/Library/Preferences/kicad.
Note: You should exit the KiCad application before doing this.

  1. Exit KiCad if it’s open
  2. Rename as follows:
    eeschema -> eeschema.backup
    kicad -> kicad.backup
    kicad_common -> kicad_common.backup
    sym-lib-table -> sym-lib-table.backup
  3. Reopen KiCad
  4. Create a new project
  5. Open EEschema schematic editor
  6. At prompt for Symbol libraries, choose the first option “Copy default symbol library table (recommended)”

Thanks!