KiCad-4 on Linux mint 16


#1

Hi,
I tried to install KiCad-4 on my Linux mint 16, but always get error because of not finding the packages. The system then install the KiCad version of 2012 - a very old one.
On the KiCad-Homepage they explained two ways to get KiCad. One is the package manager and one the shell. I tried both and it don’t works.
Here is one of the messages of the shell:
W: Fehlschlag beim Holen von http://ppa.launchpad.net/js-reynaud/kicad-4/ubuntu/dists/saucy/main/source/Sources 404 Not Found
E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.
Best regards
Hoopi


#2

I don’t know why Linux users so often have trouble with installation, it always seems overly complicated on Linux.

Since @davidrsb claimed “Linux users are on average at a better technical level to find any issues than Windows users” I will volunteer him to answer this question :slight_smile:


#3

If you look under http://ppa.launchpad.net/js-reynaud/kicad-4/ubuntu/dists/ there is no subdirectory saucy. There might be a problem with the packaging. (I can’t test it. I don’t use debian based systems.) You might want to look in the bugtracker if anyone else has problems with this ppa. (Also why the fuck is kicad 4 not in the official release of debian based systems? How slow are they to roll in “new” software?)

By the way: what is wrong with the kicad devs and their naming of stuff ( saucy, vivid, wily,… What does this mean? It’s as meaningless as pretty and sweet. Might be fun but not helpful for outsiders.)


#4

That is Ubuntu naming, not Kicad.


#5

Hello folk,
I installed KiCad successfully under windows 7 and additionally under my Linux Mint inside a VituelBox with a running Windows.
But directly under Linux there is no option to have success. I also changed the directories manually inside the package manager to directories I’ve found on /js-reynaud/kicad-4/ubuntu/dists/trusty/main/source - with some other error messages. I think, my problem is to have not enough experience with installing programs on Linux and the second problem is the not very clear way to do such things. On the other hand Linux shows not the best support for software problems.
Is it possible, that my Linux Mint 16 has to be changed to a newer version?


#6

Correction: Under linux mint. There are many other distros where kicad 4.x can be installed from the official repos. (Fedora has quite good support for the stable release, The nightly builds on the other hand are lacking. On arch it is also quite easy to get kicad to run.)

Again depends on the distro. Ubuntu (and mint) craters towards the beginners and has very nice support for everything that a beginner might need. (They have their own support forums.)

Arch and slackware (as extreme examples) fokus on advanced users and therefore have a much better support for advanced topics like using unsupported software, compileing from source, …

I’m not sure why kicad 4.x is not in the official repos for mint. (Is it in the repos of the current ubuntu or debian versions?)


#7

Because of the library dependencies and their respective versions. But Kicad 4.0.5 is readily available in the ‘backports’ branch for the stable release: https://packages.debian.org/jessie-backports/kicad

My guess is: Same as with Debian stable, Linux Mint 16 could simply be too old (it was released in 2013), i.e. the libraries Kicad 4.x depends on are not available with the required versions.

@Harald_Hoopmann: With Linux Mint 18.1, Kicad 4.0.5 is available from the Mint package repositories.

Another possibility (without any guarantee for the outcome) is to unpack the .deb-file for Kicad, manipulate the configuration file containing the dependencies and change the required versions for the libraries to those available on your system, repack the .deb-file and install it manually with dpkg. I’ve done this a few times, but would not use this way for ‘mission critical’ and production systems unless thorough test haven proven the stability.

It might be easier to back up your whole system and try an upgrade to a newer version of Mint. I’m sure Kicad is not the only software lagging behind on a Mint 16 installation.

Edit: If you are inclined to hang on to your Mint 16 installation, you could also try and pull the kicad and kicad-common backport packages from here https://packages.debian.org/jessie-backports/kicad and here https://packages.debian.org/jessie-backports/kicad-common (see bottom of the pages for the different 32 Bit / 64 Bit and architecture builds). After download try installing them with root/superuser rights with ‘su dpkg -i ./package_name’. This may or may not work (Debian stable still is roughly 1 1/2 years younger than Mint 16, but since Debian is more ‘conservative’ there may be a chance that it has the correct library versions and this works out).