KiCad 3D Viewer, Cannot Unselect Models

When I search for this topic, I find lots of questions about 3D packages not showing up. I have the opposite problem – I can’t get a package NOT to show up.

I made a part using a step file from a third party. Just for fun, I decided to try a similar wrl 3D package from the KiCad distribution libs. In the footprint editor’s 3D package view, I can clearly see both models, select and unselect them properly using the Preview checkboxes. All looks good.

But when I invoke the 3D view of my board, both packages are displayed, regardless of the state of the Preview checkboxes. I’ve confirmed the checkboxes are selected correctly (as I perceive correctness) in the library itself and in the part on the PCB layout.

In the 3D package preview window, these Preview checkboxes toggle the display of a model on and off. For purposes of the 3D viewer, is there some other way to enable / disable the display of 3D models?


Application: Pcbnew
Version: (5.1.9-0-10_14), release build
    wxWidgets 3.0.4
    libcurl/7.64.1 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.41.0
Platform: macOS Version 10.16 (Build 20E241), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
    Boost: 1.75.0
    OpenCASCADE Technology: 7.5.0
    Curl: 7.54.0
    Compiler: Clang 10.0.1 with C++ ABI 1002

Build settings:

“Preview” is just what it says, a preview. The checkboxes are only for the preview, not for the board.

Only in version 5.99 (the unstable development version leading to v6) it’s possible to use real “Show” property which affects the board, too.

A workaround is to add an extra character to the file name so that the file isn’t found, then it’s ignored in the preview and in the board.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.