KiCad 3D View of Polarized Capacitors


#1

So I have a couple of polarized caps on a board, when I 3D view it, they showing way over sized.

C2: CP_Raidial_D12.5mm_P5.00mm
C4: CP_Raidial_D10.0mm_P5.00mm
C8: CP_Raidial_D8.0mm_P3.500mm

See album for screens: http://imgur.com/a/B6NA9


#2

update your 3d files
footprints are taken automatically from github. 3d files are not. (yes this should probably change in the future)

Until a few weeks ago the wrl files of these capacitors where not scaled correctly and the scaling was done via the footprint settings.
@Shack created new 3d models in step format and scaled the 3d models correctly.
You still have the wrongly scaled 3d models on your system.

Download the 3d files either from the main lib repo or from our new packages3d repo. Or even better check out the git repository. This way you can update the lib when ever you want (git pull). The packages 3d model does not yet include all models that where available in the old lib.

Place the files either where KISYS3DMOD points currently (somewhere under c: for windows, /usr/share/kicad/modules/packages3d/ for linux)
Or place them anywhere on your system (example your home directory) and change KISYS3DMOD accordingly. (kicad main window->preferences->configure paths)

In the nightly builds there already exists a 3d files downloader. This operation will be a lot easier under kicad v5.


#3

@Rene_Poschl
Thanks you very much, and thanks to @Shack and all others developers and contributors!

I faced the same issue that OP have stated; at present I’m dodging it by scaling the capacitor 3D shape in PCBnew: right click on the capacitor (or whatever component) -> Footprint Cx on F.Cu -> Edit Parameters -> 3D Settings tab -> 3D Scale and Position -> Shape Scale -> 0.4 for X, Y and Z works fine for my oversized capacitors.

Now I’m downloading the new 3D files… I hope it works…

BTW: PCBnew has its own Preferences -> Configure Paths menu.
In your opinion, is preferable to replace the old 3D shapes in /usr/share/kicad/modules/packages3d/ , or to add the new shapes to my own 3D directory (/home/daniel/KiCAD/Library/3D/ in my system), and declare it in PCBnew KIOWN3D variable?
In second case: is necesary to delete/rename the default 3D directory, to avoid file colisions (same file name at two different paths)?

I’m developing my first project using KiCAD (and is my first electronic+PCB project too); I’m feel so comfortable with KiCAD (despite I’m never ever have worked on another EDA software). I’m not electronics engineer nor technician…

I’m learning and finding more and more KiCAD features, and enjoy that.
The main feature I missed is Interactive Router: I’m running my system (Arch Linux) on an old Lenovo R60e, its graphics card only supports GLX = 1.4, OpenGL Canvas requires GLX >= 2.1 :frowning:

Best regards,
Daniel
P.S.: forgive me for my bad english, I’m argentinian and only speak spanish…


#4

I think it should be KISYS3DMOD which is set in the main window preferences->configure paths.

I personally go this route. (I clone the repo and use git pull to regularly get the newest files.)