KiBuzzard plugin on Windows

Is anyone successfully using KiBuzzard plugin on Windows?
I can’t get it running because the self-generated Paths seem wrong.
I get an error: can’t find specified path, where the path is:
" C:\Program files\KiCad6\share\kicad\scripting\plugins/KiBuzzard/KiBuzzard\…\deps…\typeface/. "
Looking at the code, the path is generated internally by some os.path.join functions and seem wrong.
Just by looking at using the “\”, “” and “/” separators, the “…” also seem wrong.

OK: the path was not the source of problem, although it does not seem right.
I have not downloaded the ‘buzzard’ code (which is a dependency, and manual download does not get the dependencies).
Unforutnately this plugin does not work for me (displays dialog window, if I hit “Generate” the dialog is greyed out but nothing useful happens).
Any hint from someone who have success, is welcome.

At least share a link where people can get the stuff you are talking about.

Looks like plugin is expecting python 3.8 to be installed in c:\python38 for windows, see source

Do you have python installed there? Did you install requirements as said in docs?
pip3 install -r requirements.txt --user
Here pip3 needs to be the one from c:\python38 as far as I understand.

This message “Can’t find the path specified” is related to python.exe path error in __init__.py inside the second KiBuzzard directory i.e. plugins\KiBuzzard\KiBuzzard\__init__.py

Scroll down to line 88:

process = subprocess.Popen(['C:\\Python38\\python.exe', buzzard_script] + args, stdout=subprocess.PIPE, stderr=subprocess.PIPE, shell=True)

and change it to:

process = subprocess.Popen([buzzard_script] + args, stdout=subprocess.PIPE, stderr=subprocess.PIPE, shell=True)

Also note that you need Python 3.8.x because you will be able to install all dependencies found inside requirements.txt. First clone the plugin recursively to make sure all required files are downloaded, and then open a cmd window inside plugins\KiBuzzard directory then issue the command:
pip3 install -r requirements.txt --user

One more thing to take care of is to define a new path variable pointing to f2py.exe, for example mine is located at: C:\Users\<user account>\AppData\Roaming\Python\Python38\Scripts

I have also put this on github.

Snapshot below is for KiCAD 5.99 on Windows 10:

1 Like

Sorry man, didnt see ur post earlier!

I have Python 3.8.6 as part of Win10 install that lives inside \program files\windowsapps
I don’t have any package manager installed, so I just tried to download the code from GitHub

Seems it’s more complicated than I expected…

Here is a videoI created that shows you how to install it on Windows 10, sorry for the 720 resolution I forgot to modify the settings before recording!

How to isntall KiBuzzard on Windows 10

1 Like

Thanks, all is working now. I was probably missing the dependencies.

1 Like

Glad to see it working for you :slight_smile:

Related https://twitter.com/GregDavill/status/1360560415462227973

1 Like

One small addition to your guide, @elekgeek (thx for it btw, it brought me close enough to finally running the plugin!):

When one has an editor like VSCode configured to open .py files, if one clicks on “Create” in the plugin menu,
subprocess.Popen([buzzard_script] will open VSCode (!) instead of running the script.

As I am using the msvc builds directly from KiCAD, I changed that line to :
process = subprocess.Popen(['C:\\Program Files\\KiCad\\5.99\\bin\python.exe', buzzard_script] + args, stdout=subprocess.PIPE, stderr=subprocess.PIPE, shell=True)
and now everything works fine.

Also, I had to modify requirements.txt where I removed the bezier and the numpy line, because the first wouldn’t install without asking for an PREFIX INSTALL PATH or something along those lines, numpy was already installed and for some reason, this line was creating lots of errors too.
so, just pip3 install bezier did the trick for me.

Maybe there is a cleaner way, but I am less than a greenhorn in Python, and this method just worked on both my two Windows 10 installations

PS: I used the pip3.exe from the msvc Kicad install

1 Like