KiBoM - Python BOM Generation tool


I would like to see matching of components on their Manufacturers part numbers, MFPN. This is generally considered a good thing to add. I wish it was a default field in Kicad already, now i add it manually, but since it is a bit tedious for resistors and such, could their be some kind of configuration, so that i migh manually add which fields to group on.

That way i could use the MFPN for most parts, and leave tolerance and such empty, for resistors i could instead leave MFPN empty, If i then create my groupings based upon both MFPN and Tolerance for example, i would get the groupings i wanted.

Thanks for your script and effort anyway!


Hey all,

I have made some improvements to the script (the file explains them all)


a) Grouping columns can now be specified by the user in the .ini preferences file (you can even remove the default grouping columns if required)

b) The regex matching now works on a component level. You can specify various regex to determine if an individual component is included OR excluded (read the docs!)

c) The logic by which a part is “fitted” or “not fitted” is now simplified and explained

d) You can specify that individual components will be included or excluded with “configurations” i.e. only load some components in the “Production” build. This is all laid out in the docs.

e) You can specify in the .ini file if blank fields should count as a “conflict” (making a new line in the BoM) or if they will be merged with a non-blank field where all the other fields match


Hi @SchrodingersGat
I found a little bug when the script is writing html output in case of utf-8 chars (in my case it was 125°C)
I had to substitute

        html.write('\t<meta charset="ISO-8859-1">\n') #UTF-8 encoding for unicode support


       html.write('\t<meta charset="UTF-8">\n') #UTF-8 encoding for unicode support

probably it is just an oversight, considering your utf-8 comment :smiley:
thanks a lot for the new implementation of the grouping fields



Thanks for the heads-up @maui, fixed :slight_smile:


I will append my issue here since I believe it is pertinent to the thread.
I am trying to use the KiBoM tool with the PCB Configuration feature. But I can’t make it work.
I’ve added the fit_field to the schematic and filled with the required information.
The i’ve updated the BOM.ini file with the following information.
> ; Field name used to determine if a particular part is to be fitted
**fit_field = ‘**C00001’

I need to remove from the BOM file the items that are marked as “-C00001”

The only clue that I’ve is that the tool is issuing a warning saying “Field conflict: (J8 J17 J18) [fit_field] : ‘-C00001’ <- '”+Debug"’"
And looks like it is being generated because two different instances of the same part have different “fit_field” information

Anyone has used this feature before?

Thanks in advance


Hi @mcarra there’s a slight misunderstanding in your usage of the fit_field parameter.

The fit_field must specify which field the script looks in to determine if a particular part is included in the BOM. In your example above, you have defined this as C0000:

Which means the script looks for a field called C00001 (which does not exist).

If you change the line to:

fit_field = 'fit_field' then it should work with your current field naming. Or you can change this to whatever you want.

The key is that you do not specify the contents of this field in the .ini. file



I’ve corrected my bom.ini file with the following statement:

fit_field = ‘Config’

then i’ve updated the Config field with the sentence “-C00001”

Saved all and run the BOM tool with:

python “/home/cmartin/Desktop/KiBoM-master/” “%I” “%O” “-r C00001”

And the part is still there:

Any clue?

Thanks in advance.


Sorry for the delay.

In your command line argument, remove the quotes around “-r C00001”


python "/home/cmartin/Desktop/KiBoM-master/" "%I" "%O" -r C00001


Excelent! It worked as expected!

I have another question regarding the tool: Can I set the fields that I want to show in the list?
As I can see from the documentation the tool automatically appends the field if it appears in one of the components.

I only want to see reference, value and ManufacturerPN

Any Idea on how to do this?

Thanks in advance!




I keep getting an error message when using KiBoM. Have added and pressed Generate.
Found one similar error, that suggested to resave the .sch file to ANSI. But this had no effect.

Command error. Return code 1

Error messages:
Traceback (most recent call last):
File “C:/Program Files/KiCad/bin/KiBoM/”, line 160, in
output_file = fname + “_” + net.getVersion() + “.” + fext
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xf8 in position 65: ordinal not in range(128)


Hi @Martin123 I’ve fixed a few similar errors recently - it would appear in this case that the schematic version text contains some non ASCII characters (or the schematic file name itself).

Can you post the contents of your schematic filename and version / revision string so I can run some tests here and fix the issue?


Thanks for the quick reply.
I just sent you the entire project in PM