Keeping last used trace width


Kicad 5.99, last build , Ubuntu 21.10

Some time ago, I was using some setting which allowed to use the same width as the trace
I’m editing. Example: rerouting a segment. delete the segment, redo it with a different route.The
PCB software was keeping the same width as the currently remaining segments.
Now I’m working on another layout, but I can’t find how to enable this feature. Any hint?


The icon with the coloured background beside your pre-defined track sizes?
Top LH corner under the save logo.

Is that what you are looking for?

You can use net classes to set the width of different types of tracks - e.g. You might set a wider ‘power’ class and allocate a number of nets to this class. When you route any net in the 'power ’ class it will automatically use the width allocated.


Hello! Thanks for your replies.
Yes, the picture seems to do what I want, but how do I set it?
I have tried to right click one track, look in the track width menu, etc,
but I don’t see any checkbox or whatever that seems to do this.
If you could give some explanation, it would be great.

Click on this icon: image

In my previous screenshot my mouse cursor was on it, but my screengrabber did not grab it.

Hi, seems to be a problem here.

@roboya is using:

And @paulvdh has posted for 5.1.x

In KiCad-nightly V5.99 it’s this one:


Thanks! It works!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.