Just installed V6 and no sysmbols in editor

Hello, Downloaded V6 and there are no symbols when adding. I probably made a mistake when first running and didn’t install the libraries correctly.

Would apprecaite advice on how to correct please?


What OS? What method of downloading and installing V6? I know some Linux distro’s have the libraries as a separate package.

Using W10 and downlad from CERN server. The symbol path is shown correctly but the table is blank as is the footprint table in PCB. When I isntalled a popup window ‘Configure Global Footprint Library Table’ appeared and this is where I went wrong I think.

I had the exact same issue. The “Recommended” option was grayed out and there was no way to import the default libraries.

I got around the issue by copying “sym-lib-table” and “fp-lib-table” from “C:\Program Files\KiCad\6.0\share\kicad\template” to “C:\Users{{USERNAME}}\AppData\Roaming\kicad\6.0”

yup a few gentoo users were hit by this as well :frowning:
Some copies the sym-lib files others deleted the settings directory and let kicad regenerate it (this is what I did).

Thanks for the suggestions. I will have a look at those options.

When you say the “settings directory” which directory are you referring to please?

BTW the footprint library was also empty and probably the 3D library list as well.

The footprint libraries work in the say way than the symbol libraries, so the problem is probably the same. The 3D libraries are different: each footprint refers to a 3D file path which may have a path variable. If you can use the official footprint library, then most probably the corresponding 3D models work properly, although the official libraries don’t have 3D models for all official footprints.

I used your suggestion of copying “sym-lib-table” and “fp-lib-table” to the users folder and that has solved the problem. The original folders were empty.

Thanks again for all the suggestions.

Since a number of users have reported problems on various platforms, I want to give some tips and also list the known ways this problem can happen. There may also be unknown ways that we need to uncover.

The symbol library table and footprint library table files store the library setups for each KiCad installation. For a while now (since some point during the 5.99 nightly builds), KiCad supports versioned configuration directories, meaning that each KiCad installation can have its own library tables.

A symptom of “no libraries found” usually means one of two things:

  1. The library table file is missing or empty
  2. The library table file contains references to libraries that KiCad can’t find.

(1) normally happens when you install a “lite” version of KiCad (for platforms that support this concept) which comes with no libraries. The first time you launch KiCad and start the symbol or footprint chooser, you’ll be asked how to set up the library table. The recommended choice of copying the default library table will be greyed out, because in the lite version, no libraries are available. Unless you manually choose a valid library table in this dialog, any action you take here will result in empty library lists. This should never happen for a full-version KiCad installation. If you see this happen, it’s a bug either with the packaging or KiCad itself that needs to be reported.

(2) normally happens when a newer version of KiCad is using an older library table. For example, if you continue using a KiCad 5.1 library table with KiCad 6. Because this doesn’t work, we don’t support migrating library tables from old versions even when you choose to migrate other preferences. However, there was an issue where earlier release candidates of 6.0 did allow you to migrate your library tables, which would result in broken library configurations.

Therefore, it is a known issue that if you installed an early release candidate / nightly build of 6.0, and you chose to migrate your preferences from an earlier version of KiCad, you probably faced the problem of missing libraries. This should not be possible anymore with the stable release of 6.0. If you see this problem, it’s also a bug that needs to be reported.

We are currently unaware of any root cause of this happening on any platform, however we have had several Ubuntu users report that the default library tables (for example /usr/share/kicad/template/sym-lib-table) did not get updated to the 6.0 version when they updated the kicad package from 5.1 to 6.0. This results in the above problem, and can be fixed by completely uninstalling kicad (check that there is nothing left in /usr/share/kicad) and reinstalling it, and then removing the symbol/footprint library tables from your preferences folder (~/.config/kicad/6.0/) in order to get prompted to copy the global defaults again.


I have downloaded V6 for Windows 10 and am totally confused at installing it as I to have no symbols in the editor. I have removed 5.12 that I had installed and currently have V6 asking to “configure Global Symbol Library Table”. I have two of the 3 options available:

Copy custom global symbol library table
Create an empty global symbol library table

Copy asks for a file I don’t seem to have so I go “Create” but when I go into a new project and open the schematic editor I get no components listed when I try to add one.

I don’t understand what this global library is, I have tried searching and this post is about as close to the problem that I have found. Reading the post just above mine I am not sure where I should look in Windows (it seems there are files located in the AppData folder, program install folder and in the documents folder).

Is there an “I’m stupid Windows user and need hand-holding to install KiCad correctly” guide somewhere? It seems I am being dumb and missing something as I just can’t seem to get any schematic symbols to appear (even though there are loads of lib’s in the “Program Files/6.0/share/kicad/symbols” directory)

The first option is the ideal option (“Copy default global symbol library table”); I’m not sure why it’s grayed out if you have installed the libraries with v6, which it sounds like you have. Seems like a bug?

In any case, since you can’t choose the first option, go with the second option: “Copy custom global symbol library table”. Browse to <KiCad 6 installation directory>\share\kicad\template\sym-lib-table and use that as your symbol table. (For me the path was C:\Program Files\KiCad\6.0\share\kicad\template\sym-lib-table.) The effect will be the same as if you had chosen the first option.

You’ll most likely have to do the same for footprints when you first open the footprint editor – go to the same folder and select fp-lib-table.

1 Like

That got it! Awesome, thank you!!

1 Like

I upgraded from KiCad 5.1.x to KiCad 6.0.1 on Ubuntu 20.04 and had the same issue that I still had the old libraries from 5.1.x (verified with dpkg --list | grep -i kicad).
I was about to do a reinstall, but then did a software update using apt update && apt upgrade, then after that the correct libraries was installed, verified in the same way as above.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.