Junction Dot Size?


#1

I don’t know what to think about this:

junction_dot

Anyone have some ideas/?

On Edit: Same issue:

junction_dot_2


#2

They become virtually invisible on normal zoom levels if you set size to 0.0
I would bet it’s related to the recent antialiasing changes that do pixel alignment.


#3

Might be. It’s best to start with “no antialiasing” and then test other settings. I have found all antialiasing lacking. It’s not about KiCad quality but the nature of antialiasing which is that exact pixels are changed to non-exact with different kinds of algorithms. And of course “no antialiasing” requires algorithms and finding the approximately best option, too.


#4

It’s always a minimum of 1.5x the line width.

https://bugs.launchpad.net/kicad/+bug/1545422


#5

Does it have to be?

I’d like them to be less then the thickness of the lines, so that they appear to go away.


#6

File a bug report and we can see how to fit your request with others’.