Its looking for deleted lib location

New here,
Kicad 5 keeps looking in a deleted folder for old libs.
I uninstalled a few times and removed from global path.
Where is the hidden place that does not uninstall ?

I just did an install of V5. I had some issues with libraries but as long as I changed them in ‘Preferences > configure paths’ it seemed to get to the correct library for me. What OS? In Linux there is a ./config/kicad directory.

Sorry windows.
I do not see error in environ var config.

Are you running eeschema in stand-alone mode?

No, i am running the full kicad 5.
When i try to bring up sch capture it runs thru lib a while
Then starts getting hung looking for aliases. It seems there is something not getting uninstalled and pointing to a old location. Registry perhaps ?

Did you upgrade from v4? If so, check out this FAQ, especially the procedure linked at the end for upgrading to the new library organization that comes with v5.

No, i am new and only have had kicad 5

There must be some file or data left behind that
Prevents a clean reinstall. I am unable to open the schem
Editor because of my problem.

Try this:

  1. With KiCad not running, go to your user settings folder (it is normally hidden in Windows):
    For example, if your username is JohnDoe then your user settings folder would be:
  2. Change the folder kicad to kicadBackup (or, really, anything that isn’t kicad).
  3. Start KiCad and see if everything works for you.
  4. If it does, feel free to delete the kicadBackup folder.
    If not, delete the new kicad folder and rename kicadBackup back to kicad. This excercise didn’t work, but now you were back where you started for someone else to try to figure out what went wrong. (This is my last idea…)

I hope this works for you.

1 Like

Thanks for your effort, but i do not have appdata under any profile.
This is most frustrating.

AppData is normally hidden, you need to select “Show hidden files”.

But really, users rarely need to edit the KiCad config files. You can do all library management from the library table managers. Just delete the library from the table in the KiCad library table manager.

Confusingly, the installer doesn’t install library files in to KiCad, it just copies them to the disk. You install libraries into KiCad by adding the library to the respective table.

I see users getting confused about these two things all the time.


It is really just a shortcut instead of deleting all lines in the table and then re-importing the libraries all in the manager. The package libraries have tables properly built for the libraries in the package. If KiCad can’t find the library tables in the user settings area (what ever OS is being used) it will copy the table from the package to the settings folder.

And for the schematic libraries, this is the only way to get the library description as supplied by our intrepid librarians. I have a wishlist item on the bugtracker for an optional manifest file for libraries, but I’m sure that is way low on the dev’s priorities, even for v6.

1 Like

Thanks for all replies.
I think that I am ok now.
Between the replies above and a low level youtube vid

It looks like a environmental path in both symbols and
footprints is non volitale,even when uninstalled and reinstalled.
Again, thanks for your help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.