Issue with running local build on Windows 10


#1

I have built KiCad on Windows 10 by following these instructions. However, I get the error “Failed to load kiface library” (image below) when I press the “Schematic layout editor” button in KiCad. If I copy the _eeschema.kiface file to the folder which contains kicad.exe, the “Schematic layout editor” button works fine and I do not get this error.

Apparently, my build does not have all executables and kiface libraries in the same directory, which kicad.exe seems to expect. What is the correct way to fix this problem?

"Failed to load kiface library"

Besides, I can only launch kicad.exe from MSYS2 shell. I get an error if I try to launch it directly from Windows.

Version details:

Application: kicad
Version: (6.0.0-rc1-dev-641-g3f6819e59-dirty), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.33.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

#2

Don’t try to run kicad from the …\kicad\build\release\kicad folder, use …\msys64\mingw64\bin.


#3

What I did is installed a nightly build in KiCad-dev directory and then pointed to that directory as CMAKE_INSTALL_PREFIX option. Now when I run cmake install it just builds and copies over new files to that directory and all the dependencies that are not part of main source tree are already there from nightly build so everything just works.


#4

Thank you @bobc for pointing to the correct directory. I can run KiCad now.
Thank you @qu1ck for mentioning the CMAKE_INSTALL_PREFIX option. I was thinking about changing the output directory and this option may do it. I should learn more about these cmake options.