Issue with Hiding 3D Models in KiCad PCB Layout Editor

I’m encountering an issue with hiding 3D models in the KiCad PCB layout editor. Despite my efforts to hide certain 3D models associated with footprints in my project, they remain visible in the 3D view. Here’s the specific scenario:

I've created a project in KiCad and imported custom footprints from my local library.
Some of these custom footprints use associated 3D models from the KiCad system library.
While attempting to hide these 3D models in the PCB layout editor's 3D view, they remain visible despite toggling visibility options.

Key Points:

The footprints are sourced from my local library, but their associated 3D models are from the KiCad system library.
Despite hiding attempts within the PCB layout editor, the 3D models persistently appear in the 3D view.

Troubleshooting Steps:

I've verified that the footprints themselves are correctly sourced from my local library.
I've attempted to adjust visibility settings within the Footprint editor, but this does not affect the visibility of the 3D models.
I've considered possible cache issues or prioritization of library links but have not found a solution.

Request for Assistance:

Could the issue be related to how KiCad prioritizes library links or caches 3D model data?
How can I ensure that my project's custom footprints correctly hide their associated 3D models in the PCB layout editor's 3D view?

KiCad version info:
Application: KiCad x86_64 on x86_64

Version: 7.0.11-7.0.11~ubuntu22.04.1, release build

wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16

Platform: Ubuntu 22.04.4 LTS, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
Date: Feb 21 2024 19:16:04
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.6.3
Curl: 7.88.1
ngspice: 38
Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

Any guidance or insights on resolving this issue would be greatly appreciated. Thank you!

Exact KiCad version?

I’ m sorry for missing that : KiCad 7.0.11

BTW You can easily switch to the new v8 release. Projects will open without problems. Help on topics before the current versions could be delayed :wink:
I checked a demo project in an old v7.0.9 and easily can show/hide the 3D models of some footprints. This is done by changing the “Show” flag of the specific 3D model in the footprint property (not library footprint property):

Did you do something different? Could you please check this in the current version?