Issue with Debian buster backports

Because I had to reinstall my Debian 10 Buster OS today, I followed the backports installation guide at to get back to kicad 5.1.4.
(the default installation is stable kicad 5.0.2)

I readded the buster-backports.list file:
root@solydk1:/etc/apt/sources.list.d# cat buster-backports.list
deb buster-backports main contrib non-free
However my first try failed:
root@solydk1:/home/user# apt-get -t buster-backports install kicad
E: Malformed line 1 in source list /etc/apt/sources.list.d/buster-backports.list (type)
E: The list of sources could not be read.
E: Malformed line 1 in source list /etc/apt/sources.list.d/buster-backports.list (type)
E: The list of sources could not be read.

Any idea where I might have erred ?

That’s not a good way to present a file here, but:

Is the first line you command line and the second line the first line from the file? That shouldn’t be in the file or must have # as the first character - it was meant to be a comment in the file.

Also, aren’t you supposed to do an apt-get update before any install?

Yes, thanks for the reminder.
Actually whatever I did seems to have screwed up #apt-get update too:

root@solydk1:/home/user# apt-get update
E: Malformed line 1 in source list /etc/apt/sources.list.d/buster-backports.list (type)
E: The list of sources could not be read.

OOPS – I seem to have mangled my original post. Should be
user@solydk1:/etc/apt/sources.list.d$ cat buster-backports.list
deb buster-backports main contrib non-free

As eelik says the first line should not be there. Every line should start with deb or be a comment.

Thank you, kenyapcomau.

Okay, I successfully installed Kicad 5.1.4 this morning using the technique I described earlier. Thanks for your help, eelik and kenyaapcomau.

However, kicad appears nowhere in my KDE Plasma menu. I can start kicad from the command line, and my circuit looks normal. But I haven’t yet tried any operations with this new version of Kicad.

Under the Settings…System settings…“Qt5 Configuration tool” appears the message “The application is not configured correctly.”
So I rescanned the apt installation STDOUT for error messages, but found no error message or warning.

If anybody knows how to correctly configure Kicad under KDE Plasma Version 5.14.5, KDE Frameworks Version 5.54.0, Qt Version: 5.11.3, Kernel Version: 4.19.0-5-amd64 I would appreciate your guidance or suggestions.

My Kicad version is
Application: KiCad
Version: 5.1.4+dfsg1-1~bpo10+1, release build
wxWidgets 3.0.4
libcurl/7.64.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-5-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.64.0
Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:

1 Like

It’s not clear that message is relevant, since Kicad is not a Qt app but uses Wxwidgets. Probably the qt5-ct is complaining that there are no Qt settings for this app. Since the app runs fine from the command line, maybe all you need to do is create a desktop launcher for Kicad under KDE.

I appreciate your suggestion, Ken. I followed the instructions at
to add kicad to the KDE desktop. That works fine.
I tried to copy it and paste it to the kickoff menu (the K button), but that did not work. I see the Development line in the kickoff menu is grayed out. Maybe that is why KDE did not place the Kicad icon in the kickoff menu? In a previous incarnation of KDE, IIRC, APT placed the Kicad icon under either Development or Education. I don’t recall which.
I also copied and pasted the Kicad desktop icon onto the KDE application launcher. Problem solved.

Are there any email addresses for the package maintainers in the documentation or the repository? I’ve started compiling but when I did use the repos there was always an icon in the menus. Are you just going through the menus or do you type to search?

Sure. :wink:
Just use zless /usr/share/doc/kicad/changelog.Debian.gz or apt changelog kicad.

But to give some more explanation.
The binary apt or dpkg doing nothing special here regarding the KDE desktop. apt is one of the high-level packaging tools (there is also apt-get, aptitude, synaptics etc. available) and dpkg is the low-level packaging tool. apt is controlling dpkg calls.

The KDE DE (Desktop Environment) is using the typical metadata that the kicad package is providing. And these are the .desktop files for the various usable binaries placed in /usr/share/applications.

$ dpkg -L kicad | grep desktop

So something is going wrong here as KDE seems to ignore these files or is somehow unable to read the files and include the into the internals of the DE administration.

It’s a while ago I used a KDE DE but at least KiCad was already on version 5.x and it worked well. Mostly something is misbehaving due screwed up local profile config files. That’s easy to check, just create a new user and lock into this new users profile. All local config files are created from templates and should behave as desired. If all is working well here than you need to dig into your users profile config settings.

Make a backup of the folders ~/.config and ~/.local and log out and newly into your profile so you get new default settings. The rest is a bit tedious comparing of both profiles.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.