[Issue] Lines Style in Footprint Editor does not work

I tried to change Grid Style in Footprint Editor from Dots to Lines. But it did not change

  • My action
    Preferences > Footprint Editor > Display Options > Lines
  • Version: Kicard 5.1.5-3
  • OS: Window 10

I changed the grid also to lines in the Footprint Editor just to verify this, and for me it works as expected:

Note: Try to make screenshots from small windows. It makes them easier to read on the forum.

My version:

Application: ModEdit
Version: 5.1.5-52549c5~84~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 5.3.0-40-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.4.0 with C++ ABI 1011

Build settings:

I run kicad on Window 10 Pro. Your version is same to me. I try again, the issue still happens

Do you know where i can submit my issue to fix? Thanks

Have you Modern Toolset selected?

Sorry i dont understand what you mean. I am newbie :frowning: . How can i enable Modern Toolset?
In my case, i can enable Line grid in Schema and pcb without footprint editor. Thanks

I tried to use all toolsets but it does not work

For me (Windows 7) it works in Modern Toolset and not works in Legacy Toolset.
Have you opened any footprint (at your first screenshot it looks that not)?

In those my message I have cited the whole message (11 words) to show about what I am writing and the system automagically removed that citation. Who decides about it. If there is any mechanism to delete the citation of whole message that mechanism should distinguish between citing long message and just few words. The system should help to be clear in writing and not against.

After reinstalling, it works now with only modern toolsets. Thank you for your support

Just don’t use Legacy toolset. Modern toolsets are to replace it (temporarily available together). Legacy was deleted from schematic and will be deleted from PCB.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.