Issue Connecting to a Package in Newest Version


#1

Hey guys, so I updated my KiCAD, and I went to use the built in Package_DFN_QFN:QFN-48-1EP_6x6mm_P0.4mm_EP4.66x4.66mm for a ATSAMD21 and for whatever reason I cannot connect the D+ and D- lines for USB. No matter how much I move around the router, or change settings, or go outside and pray to the KiCAD gods I cannot connect them. Only these pins, I see nothing different between these and all the other pins even when I scroll through layers or change track widths.

Is this a bug or am I just not seeing or knowing something?


#2

At a guess. Kicad is treating your pair as differential whichbhas different clearances under the differential router. I Would guess its trying to enforce the spacing. And your pads are too close to allow it.

If so change the differential settings while you attach the last bit


#3

I will be honest, learning how to make pairs in KiCAD instead of Eagle is the next item on my to do list, dunno how. That is not it. But I will keep that in mind for the future.


#4

Having 2 nets that are the same. But one has “+” and the other “-” or “_P”/"_N" on the end tells kicad its a differential pair.


#5

Ah! So how can I fix the issue?


#6

Never mind, I found an easy fix that involved selecting the trace section, and pasting in the x and y values from the pad I was trying to connect to, then I simply cleaned them up after to look nice. Thank you very much for your help.