Is there a way to disable panning via arrow keys in Eeschema?

I see this forum suggests that shift+arrow keys is a viable way to pan without the mouse, but on my system (Ubuntu 16.04/KiCAD 5.1.5-52549c5~86~ubuntu16.04.1), the arrow keys pan with or without holding shift. This interrupts fine control over component placement using the arrow keys. I can’t see this in the hotkey mapping either to disable it. Is this a configuration issue on my part, or is this a general bug others are experiencing? I’m happy to provide more information if necessary.

Did you try turning off “Pan while moving object” in Preferences > Common?

Not sure if that’s exactly what you’re looking for or not…

Unfortunately, toggling that option doesn’t seem to change this behavior.

When pressing an arrow key, with our without moving an object or running a wire, the cursor moves a little bit and then the whole screen pans immediately afterwards. This two-step move happens with each press, no matter how short or long.

Yeah, I found that really annoying too. I decreased the margin width for auto-panning, but it’s not in 5.1.

If I’m following what you mean by margins and auto-panning, I can understand what’s causing this behavior, and the double step makes more sense. The kicker is that it happens even if the cursor is dead center in the screen. It’s as if the margins cover the entire window.

Is this option to change the margins in the nightlies or do I have to revert? Or is the option to build from source?

If it’s happening in the center of the screen, then something’s definitely amiss.

The change to the margins is in the nightlies. If it doesn’t fix your issue, then please log a bug – something else must be going on.

Thank you very much for the guidance. The issue is resolved in the latest nightly. If there’s any further information you need for you or the development team, I’m happy to provide it otherwise I consider the issue resolved.