Is there a "check all" or "check none" for libraries?


#1

When in Eeschema going to “Preferences” > “Manage Symbol Libraries” each library has a checkbox that makes it active or not. It is the same with other libraries e.g. the footprint libraries.

I want to use this feature to make the lookup lists more manageable. They are very long.
Since I only use a small subset of libraries in a project this means ticking a lot of check boxes. For me not feasible.

The first thing I looked for is a “check all” or “check none” option but I can’t seem to find them.

Is there really no “check all” or “check none” option in the library management dialog’s?
Thanks.


#2

You can select or deselect multiple contiguous rows by pressing ‘shift’ and non-contiguous rows using ‘alt’.
This is a fairly standard paradigm for multi select situations. This is not generally a frequent or onerous burden - not feasible seems a bit excessive.


#3

My question is not about selecting rows, but about managing 182 check boxes.

Standard paradigm options include “check all, uncheck all buttons”, a “(un)check all checkbox” and a “right-click context menu option ‘check all, uncheck all’ in combination with selected rows”. I could find neither.

On Windows I use [ctrl] for selecting non-contiguous rows.

I may very well be missing a paradigm, key-stroke combination or such.
If so I would appreciate hearing about it.


#4

Have you tried just ignoring the checkboxes selecting just try selecting/deselecting the rows you are interested in retaining using the shift/ctrl/alt keys. Shift plus select usually selects a contiguous block, ctrl/alt usually allows you to add or subtract from that selection.


#5

I think you don’t quite understand what @Tonn tries to achieve.


#6

You’ve not missed anything, there’s no way to do that.


#7

Not really sure why there is a problem here. I did try this before I posted. Perhaps this is a macOS peculiarity but here I simply shift clicked the top four libraries in the dialogue you described and pressed the ‘Remove Library’ button. I have also tried doing similar selections with an alt click. Just try clicking the row number - you don’t really need to click the individual checkboxes.

and ended up with this;

Is there anything I am missing?


#8

Yes. “Remove” deletes the line from the library table. That’s not wanted here. It’s impossible to toggle the “Active” column checkboxes in batch.


#9

Read the original request again! OP does not wish to remove libs from the library table but to disable them!

This allows easy reactivation at a later point whereas deleting would require remembering where on the file system additional libs live. (Additionally one would need to remember which libs there are. With the libs disabled one can simply read the names in the lib manager)


#10

Understood. Thanks very much


#11

The thing you search is stored as cleartext inside the lib table files. So you might be able to use a texteditor to do what you want. (Remember always make a backup first)

Look at these two lines

(lib (name 4xxx)(type Legacy)(uri ${KICAD_SYMBOL_DIR}/4xxx.lib)(options "")(descr "4xxx series symbols"))
(lib (name 4xxx)(type Legacy)(uri ${KICAD_SYMBOL_DIR}/4xxx.lib)(options "")(descr "4xxx series symbols")(disabled))

So it means adding (disabled) at the end will deactivate the library in question.


#12

Now, that’s a nice thing to know!

The file is called: sym-lib-table.
Full path: C:\Program Files\KiCad\share\kicad\template\sym-lib-table.
(Using Windows)

I can certainly work with that. It even gives me the possibility to have project specific table files.
Thank you very much.


#13

That file you are referencing is actually the default that is copied if the sym-lib-table isn’t found in the settings folder. If there is a sym-lib-table in the settings folder, the file in the program files kicad folder is ignored.

See instead: C:\Users\[user name]\AppData\Roaming\kicad\sym-lib-table
Also accessed at: %APPDATA%\kicad\sym-lib-table
You need to turn on “Show hidden files, folders, and drives” in file explorer options to be able to access them using file explorer.


#14

Found it. Thanks for the correction.