Is the Footprint Editor grid size working properly?

I’m trying to make a footprint in the footprint editor using v4.0.0-rc2-stable. I have gone to Dimensions -> User Grid Size and have set my Size X and Size Y to 25 mils. After clicking OK, the actual grid spacing does not change. Actually, it doesn’t change no matter what I have tried.

What I see (and this could be user error or lack of understanding) is that no matter what units I pick in User Grid Size, the grid size remains the same. If I set my grid size to 0.025 for X and Y and click Inches, I would expect the cursor to snap to the dots in 0.025" increments, as long as I have “In” selected in the left toolbar. What I see is that I always get 0.1 increments if I select “mm” (or 0.003937 in inches) from the left toolbar.

What I expect is to be able to select Dimensions -> User Grid Size -> Inches, then set Size X and Size Y to 25 mils. Then after clicking “In” from the left toolbar and snapping to the grid dots, I should see increments of 0.025, and the units in the status bar should say “Inches”.

The current behavior is bizarre to me and seems unusable. Is anyone else experiencing this?

1 Like

I think you need to also select “User Grid” in the dropdown on the toolbar. Then the grid will be set to the User Grid Settings. The “in” and “mm” buttons on left are ignored when in User Grid mode.


That was the problem. Thank you for letting me know!