Is it possible to reduce the auto zoom?

I am working on a layout at the moment. I am using a recent nightly version but I don’t remember that the stable release version behaved differently in this regard. I view the schematic on my smaller monitor and the pcb on the larger one. If I click on R17 in the schematic, it then nearly fills the screen in the layout. And vice versa also… If I need that coordinated view, I wanted to see it in context; some of the parts around it. This seems to me like: If you want to look at a car, you don’t start off with a magnifying lens to examine a tire tread. Is there any way to reduce (or eliminate) the zoom that happens between the two? Have I missed something?

BTW this is an annoyance but not a bug. I am actually doing some work with it and so far I have not hit any serious bugs in this particular release. I did report one in which I could not see the top copper layer even though it appeared to be turned on. Something weird going on with the layer visibility presets, and switching the presets got me going again.

Application: KiCad

Version: (5.99.0-2908-g9a4f92dfd9), release build

wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0

Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Aug 21 2020 11:01:41
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OCE: 6.9.1
Curl: 7.71.0
ngspice: 32
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:


1 Like

I have never used 5.99 myself.

In 5.1.6 the only behavior I’ve seen is an automatic pan and highlight in the other program whenever selecting a component or footprint.

No auto zooming.
I don’t think I would like that at all, I’d prefer to set my own zoom factor.

Thanks, Paul

Is there any possibility that we are both missing a setting…but you have it set one way and I have it set the other?

I gave it some 10 minutes to try to find a setting which could change this behaviour, but could not find it.

Maybe there is a slight chance the auto zoom you describes does not work on Linux, but my first assumption was it’s just in 5.99.

Maybe others can add more useful info.

Application: Pcbnew
Version: 5.1.6-c6e7f7d~87~ubuntu18.04.1, release build
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 5.4.0-42-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.5.0 with C++ ABI 1011

Build settings:


If you do not like it, and I do not like it…maybe I should file it as a bug? Any other comments from the floor (or the ceiling)?

I feel like their should be a setting. You understood the behavior I want to fix but I am trying to figure out a better description.

Bob Zwicker

You can disable the zoom behavior entirely in Preferences->Display Options->Cross-Probing (in nightlys) but there is no control for the margin around the object when the zoom is enabled.

1 Like

Thanks! Knowing what it is called is so often the key…I would not think to call it cross probing.

I note that it is necessary to check (or uncheck) the boxes in BOTH Eeschema and pcbnew, according to what you want.

1 Like


This won’t help with the 5.1 series, but for the 5.99 code, I pushed a Merge Request that allows you set how far Eeshema and Pcbnew zoom when you hit the home key. I also added the ability to hit CTRL-Home in Eeschema to zoom in to just the items on a page in Eeschema instead of the entire page including borders.

Adding the ability to also set how far you zoom when doing cross-probing wouldn’t be hard. Unfortunately, this Merge Request is stuck in limbo . I pushed it two weeks ago and none of the devs who can commit it have done anything with it. This is the merge request:

And this is the Issue I originally created for it:

Related to this, I fixed a problem with the way “Zoom to Fit” was calculating how far to zoom when cross-probing. I agree that the zoom is normally kind of overwhelming, but oddly the problem in my case was it wasn’t zooming at all most of the time. The components were so tiny on screen I couldn’t see them with any detail.

I absolutely believe KiCad users should have the ability to choose how far KiCad zooms when it’s doing any “Zoom to Fit” operation, whether that’s when you hit the “Home” key or if you’re Cross-Probing. There are defaults in the code, but they are hardcoded and unchangeable by users. My feeling is that adding a couple of extra parameters to the “Preferences” dialog is a good thing. If someone is happy with the defaults, then they can leave them alone. If they don’t like it, they have a chance to modify it.

Hi, FredP

Thanks so much for your detailed response. In fact I had underestimated the “risk” involved in diving into the nightly builds but:

  1. At the time I was in an involuntary retirement and was not doing anything so serious anyway.
  2. Since July I have a consulting gig and need something relatively reliable.
  3. I have been relatively pleased with this very recent build of 5.99 and think it has some real advantages over the last stable release I used. Highlighting of selected schematic areas is one noteworthy advantage.
  4. I find that it is not so easy to revert to the latest stable build, especially since I have expanded my libraries in 5.99. I am hoping I will be all good when 6.00 (or something higher) becomes a stable release. Right now I might just stick to my present install unless I hit some bugs which I cannot work around. I think it was last week when I installed this present build after hitting a bug (I do not remember what it was) and thought that I would try updating before complaining about a bug which might have already been fixed (and apparently had been fixed).

I am working on a mostly discrete design which is not so large.

The options you describe sound really good. Just briefly I did get a chance to try out cross probing after I unchecked those option boxes. In my situation, I find that centering and highlighting the cross probe selection without zoom works reasonably well and is significantly better than what I thought I was stuck with. I am typically viewing the schematic with a zoom factor around 5 or so, and if it stays there during cross probing that works well. If highlighting can be adequate, then centering might not even be needed but (I do not code) that sounds like it might be some more complex coding.

I particularly like your remark

as in my informal use I find no use for schematic margins and borders. I think it is a waste of time (time used in further scrolling and zooming) for any view to show a significant area of the page which does not include circuitry. I am that way with .pdf documents as well.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.