Is an autoroute function or Freeroute still available?

is an autoroute function or FreeRoute still available?
I saw some youtube videos but I can’t start it.
When I hit the FreeRoute button I can generate the .dsn file but I can’t start the FreeRouter.

I am able to do that with 4.02 release. It generates quite rubbish tracks, but It works.


This blog post has some instructions for installing it You do need to have Java installed of course :slightly_smiling:

I find it easier to run freeroute standalone, the Kicad integration doesn’t really help much.

Hi bobc,

push and shove works as explained by the article.

I was also able to download everything and launch the freerouter. Routing was done and displayed in the freerouter. However, I could not transfer the routing back to Kicad.
When I tried to save it gave me the option to save as .bin or .dsn. I forced .ses by entering the extension. The third button to reimport .ses did not give any results.

The way I use Freerouter in Kicad is as follows:

1 - Get the components laid out in Pcbnew and then click the yellow diamond icon with the up and down arrows on it

2 - Select ‘Export a Specctra Design and Launch Freerouter’, then just click save on the screen that now opens

3 - Do the auto routing and when it is done and you are happy with it select ‘Export Specctra Session File’ from the bottom of the file menu

4 - Click ‘Save and Exit’ from the file menu

5 - Freerouter now closes and you are back in Kicad, select ‘Back Import the Specctra Session File’ from the bottom of the list

6 - Click ‘Open’ on the screen that now opens and then click ‘Yes’ when asked to ‘Rebuild Connectivity Data’

7 - All your new routing will now appear

I have been using Freerouter quite a bit recently and am extremely happy with how it works and it certainly saves lots of time if you want to get a board routed quickly for testing. I usually do a few manual tweaks just to make the routing how I like it to look but this may not really be necessary.

thanks for these instructions.

Here I report my two mistakes just in case somebody else runs into a similar problem

  1. I did not “Export Spectra Session Files”
  2. I have to switch Canvas ones to get display refreshed.

I too thank you for these instructions. I got it running today and I am super impressed. I liked the interactive routing, but this is just awesome.

I have tested the Linux 64 and Windows 64 versions and both work. Actually the autorouting quality is not bad if components are placed sensibly, in my opinion much better than DesignSparks efforts

Can you explain to me exactly what I need to install and how to install it? I guess I must be doing it wrong. I can get freerouter to open just fine and it has no problem importing my board outline, but that’s all it imports. No components show up and it won’t let me route any traces. I tried to follow your instructions along with everyone else’s but it just isn’t working. The only thing it shows inside the board perimeter it the conductive area.

Any help would be appreciated!

Check the link above. KiCAD needs to know where to find it and where you install it is OS dependent.

1 Like

I think that Freerouter can’t handle roundrect pads, it also may have trouble with unicode strings. Otherwise I don’t recall seeing problems with no components loaded at all.

If you could post an example showing the problem (dsn file), then that would help a lot to diagnose it.

I would upload the dsn but the forum says new users aren’t allowed to upload. How do I tell kicad where I installed it? I didn’t see anything about that.

Put it in any cloud storage of your choice and provide a link. (google drive, dropbox, …)

AFAIk, these steps still work:

To enable Freerouter in Kicad:

1 Download Freerouter from this mirror —
2 Extract
3 Copy JAR to Kicad bin directory and rename it to freeroute.jar
4 Restart Kicad to enable freerouter middle button in pcbnew. Voila!


Here is the link. And I did exactly those directions. It still did this. When I open the DSN, no components. Only the outline of the board. Middle button works fine, takes me where I need to go. Just the DSN isn’t showing up like its supposed to I guess?

There is a problem with a component name:

(component "diesel:TRI-JUMPER"
  (place JP101 279908 -46736 front 270 (PN "TRIJUMPER-3X.1""))

TRIJUMPER-3X.1" has a quote on the end, so Freeroute can’t parse it.

Workaround: remove quotes from names.


That worked perfectly. Thank you so much. After I removed that one quote all of my components appeared and its autorouting as we speak. Thank you guys so much!

I’ve installed autorouter by putting the jar under

/Applications/Kicad/ as per Is an autoroute function or Freeroute still available?

I can launch freerouter but I get these classcastexceptions:

and it never seem to finish or show anything:

Help appreciated!

I guess I need to build from source:

Got it working from the new repo by building from source with ant. I’m on mac, so verbatim for me was:

git clone --depth=1
cd FreeRoutingNew
brew install ant
cp deploy/FreeRouting.jar /Applications/Kicad/

All good it seems, working hard for me: