IO error on attempting to save footprint to new library


I am a KiCad newbie trying to make the transition from Eagle. I’m running BZR 6253 on OS X El Capitan.

I’ve run into a problem in saving a new footprint to a new library. When I try to do so, I get the message: “IO_ERROR: library directory ‘/Users/[my username]/Dropbox/Documents/KiCad/library.pretty’ has unexpected sub-directories from /Users/jenkins/remoteroot/workspace/KiCadBuildMac/kicad/pcbnew/kicad_plugin.cpp : FootprintLibDelete() : line 1941”. “jenkins” is not a user on my machine so I believe this is an artifact of the build, and I see file paths relating to “jenkins” referenced in bug reports but not specifically involving new footprints.

Any advice as to next steps I can take to correct the problem would be appreciated. I haven’t found any obvious answers online but if there is a resource I have overlooked, I’d appreciate hearing about it as that will help me as I no doubt encounter further problems on my KiCad journey.

  • Rob

Well, does that library folder have subfolders or not?

It has no subfolders.

Build of kicad-2015-09-01 BZR 6138 does work without problem on OSX Yosemite. I suggest it

IO Error is pretty generic, but here’s what mine was:

Basically I downloaded from GitHub and it had the old directory location mapped in the fp lib table. I went and cleared it out and re-added the library and then it was good.

Thanks for the suggestion regarding BZR 6138. Where might I find this? It looks like right now the KiCad nightly builds only go back to October 2.

Thank you for the suggestion about the fp-lib-tables. I went through them and did not find any hardcoded paths, but all the paths begin with {KISYSMOD} which I take to be a variable defined elsewhere. Where might I find and change that variable definition in OS X? Many thanks for any advice.

downloadable below link

In the main KiCAD window… click on Preferences > Path Configuration

Bolor, thank you very much for the download link. That version gives me the same problem, so there must be something about my configuration that is creating the issue.

Thank you, Joan. I went to that menu and tried changing the value there with an absolute one, but no joy.


i have installed El Capitan today. It doesn’t work on El Capitan without problem. Many of mine home-brew python packages doesn’t work. therefor i did downgrade to Yosemite. It does work well. El Capitan is a last shit.

Sorry for the false suggestion. It works only well on Yosemite.
Kicad lib paths are not right set there. Below my path sitting. it can be helpful

1 Like

“tried changing” implies it didn’t stick?
In that case, have a look in this directory on your main drive:

…\Users\{your user name}\AppData\Roaming\kicad

There are a couple of files in there… the one you want is kicad_common
You can change it in there and see if it sticks?